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Introduction

GoodSync synchronizes two or more folders with files, that is, GoodSync makes sure that folders and
all files in them are the same by copying the new or updated files from the folder where they appeared
to the folder where they are old or not present and by propagating deletions.

GoodSync can be used in these everyday scenarios:

¢ Synchronize notebook computer to desktop computer via local network.
e Keep user files in sync on work and home computer via USB key.
¢ Incrementally Backup all files from main hard drive to portable hard drive or another computer.

In this Section we discuss challenges that synchronization programs face and that GoodSync
successfully addresses.

Backup vs Synchronization

e Synchronization ensures that two folders remain in sync while user may change files on both
sides. This is achieved by copying changes that have been made on the left side to the right side
and changes that have been made on the right side are copied to the left side.

e Backup is one-way synchronization, that is, the changes that have been made on the left side
are propagated to the right side but changes that have been made on the right side are not
propagated to the left side.

¢ GoodSync One-Way Forced jobs enforce the backup scenario. One-Way Verified jobs actually
make sure that no changes were made on the right (backup) side, as one does not expect
backup side to change.

Why Synchronization Is Not Trivial

Synchronization task would appear to be trivial (compare file modification files and let the newer file win)
if it was not for deletions that need to be propagated. If you delete file on one side, GoodSync will
propagate this deletion to the other side of sync job by deleting this file on the other side. The
sophistication of GoodSync algorithm allows us to propagate deletions correctly through multiple
chained folders.

Another complication is that user may decide to replace newer version of the file with its older version.
GoodSync can handle this situation correctly too, it will propagate the older file version, if it detects that
user made such replacement.

Chained Synchronization

Chained syncing is a process when the contents of several folders (e g., A, B, C and D) are
synchronized by performing synchronization of pairs in sequence that results in propagation of changes
(e.g., sync A and B, then B and C, then C and D results in changes in A propagating to folder B, then C,
then D). GoodSync can perform Chained Syncing correctly.

You can use GoodSync chains to synchronize files between Computers that are not connected to each
other.

For instance, you can synchronize files between Work and Home computer using USB disk as an
intermediary:



Insert USB Disk (or any portable disk) into Work Computer.

Start GoodSync on Work Computer and Sync between Work folder and USB disk.
Pull out USB disk from Work Computer and insert it into Home Computer.

Start GoodSync on Home Computer and Sync between USB disk and Home folder.

Embedded Jobs

Several jobs can synchronize one folder to many other folders. In addition to that, you can have yet
more jobs that synchronize sub-folders or super-folders of this folder. GoodSync will correctly record file
changes in states of all folders in which the changes occurred.

For example, you can have a folder C:\work\project that contains project whose files change often.
Folder c:\work contains other projects that are changes less often.

You have a job 'Project to Server' which synchronizes project files to an SFTP server once a day and
from this server the files are synchronized by other members of the team.

You also have a job 'Work to PortHD' which synchronizes (backs up) all contents of the C:\work files
folder to a portable hard drive once a week.

GoodSync will make sure that all changes performed by the 'Project to Server' job are visible to the
'Work to PortHD' job and vice versa.

Back to the Top

Using GoodSync
Synchronization Step By Step

Typical GoodSync user experience consists of these stages:

0. Select Folders To Synchronize

o User selects left and right folders to synchronize.

o Done only once when Job is setup.
1. Comparative Analysis

o Happens when you click the Analyze buttons.

o GoodSync computes the changes that must be made to make folders the same.
2. Proposed Synchronization Actions Reviewed by User

o Results of Analysis are presented to you in a form of file/folder tree.

o Left or Right Arrows point direction of file copy. Circle in the middle means No Copy.

o Crossed Arrow means Propagate Deletion. For instance, Left to Right Crossed Arrow
means that GoodSync detected deletion of file on the left side and it wants to propagate it
to the right side.

o Current effective direction is indicated by arrow or circle being green and thick.

o Other possible directions are indicated by gray and disabled arrows or circle.

o You can change direction of sync by clicking on the desired arrow.

3. Synchronization

o Happens when you click Sync button.

o File actions proposed in Analysis and possibly changed by user are applied to actual files.

o After synchronization folders and all files in them become the same.

Jobs



Each synchronized pair of folders is memorized in a Job.

Job also has a set of options that control various aspects of synchronization process.

Each Job has a name that is requested when Job is created.

When you start GoodSync for the first time, initial nameless job is created for you automatically.
GoodSync memorizes list of Jobs and all their parameters per computer.

Jobs can be created, deleted, renamed, analyzed and synced. All job commands are in the Job menu.

To create a new Job, select Job -> New.

To switch between Jobs, click Job tab.

Analyze, Sync, and Stop button are related to the current Job.
To delete a Job, select Job -=> Delete.

Synchronization Algorithm

This is a general outline of the synchronization algorithm (the actual algorithm is rather complex, it
contains several important inventions and trade secrets that cannot be disclosed here):

Compute difference between current file state and stored file state for the left folder,
Compute difference between current file state and stored file state for the right folder,
Propagate changes that appeared on the left to the right side,

Propagate changes that appeared on the right to the left.

If change happened to same file on both sides, declare a Conflict.

Backup Files Incrementally: One Way Sync

For GoodSync, backup is a regular synchronization that happens to be one-way. Only changed files and
file deletions are propagated to backup folder. This is how you setup a backup:

e Create an empty backup destination folder. Backup destination folder must not be located on the
same disk as source folder. It can be on removable disk (USB disk or portable hard drive) or
another computer.

e Let GoodSync do the first backup by synchronizing backup source folder to backup destination
folder.

e After that, whenever you want to backup, just sync backup source folder to backup destination
folder.

¢ When you need to restore, backup destination folder contains exact copy of the backup source
folder, as of last backup.

¢ To make sure that backup always goes one way (from original folder to backup folder and never
in the other direction), go into Jobs -> Options and select One Way Job Type.

Mini Window vs Main Window

Main Window contains the User Interface displayed to the user.
It contains:

File Tree: this is where modified files and their sync directions are shown.

Log Window (bottom of the screen): log of job actions.

Job List pane (hidden by default): displays status of all jobs. To show, go to View -> Job List .
Filters tab (hidden by default): displays Exclude/Include filter. To show, go to View ->Filters .

Mini-Window or Mini-Mode is super-compressed summary of what is going on in GoodSync.



¢ [t shows only status of all running jobs.
e Click Mini Mode button to switch from Main Window to Mini Window.
e (Click Maximize button in Mini Window to switch back to Main Window.

GoodSync File Tree Sample

" Job Name Total size of files " Total number of files | (Total size of files| File size and last
- | shown on the Ieﬂ;l to be copied to the left in the folder modification time J
q Ny 3 |I
= g 21,239 i 3 13.{(‘8 -
= . Folder 21,239 5/30/20081:46:31 PM| 140 O 323 13:'"848 5/2072008 1:41:17 PM
| filetxt 618 5/30/2008 1__:51_4__-_.}__9:.'—‘i1.'rii"'-"- FNe . 354 S 5/30,/2008 1:35:04 PM
Folder arrows change Click the arrow to ' Click the gray circle Green arrow shows the
direction for ALL items change sync direction if you do not want | current copy direction
insicle folder for the file ~ to sync the file :
Back to the Top
Actions

Action is a file/folder operation that is:

¢ Recommended by GoodSync after Analysis is complete,
e Changed by User (that is, you), and finally
e Executed when you click the Sync button.

Each actions gets anicon in the center 3 columns of the tree.

See the next Chapter for the detailed list of actions' icons.
Copy File action

This is the most fundamental action of GoodSync.

It copies file from Left to Right or from Right to Left.

Copy of file deleted on the Left from Left to Right means that this file will be deleted on the Right.
Copy of file deleted on the Right from Right to Left means that this file will be deleted on the Left.
That is, GoodSync "copy" of the deleted file simply propagates a deletion.

Copy Time action

If file has the same length on the left and right side of the sync but modification time is not the same then
you can turn Copy File action offered by GoodSync into a Copy Time action. Copy Time action copies
file modification time from Left to Right or from Right to Left, but not file contents.

A recommended way of applying it is to select View -> Other -> SamelLength DiffTime. This will show
you all files that have the same length but different file time. If you think that these files are really the
same, rightclick any of the files and select Copy Time L to R or R to L. You can also right-click the folder
and change Copy File into Copy Time for all eligible files in the folder.

Copy State action



If file is present on the left side and absent on the right side of the sync (or vice versa) or if file is
deleted on both side and this is not yet recorded in the state then GoodSync would recommend a
special Copy State L to R or R to L action for such files.

The results of the Analyze step will inform you that Copy State will be done, if this is necessary.
You can change direction of Copy State action if you know which side is preferred.

You can see specific Copy State action using View > Other -> Copy State L to Ror Rto L.

The following are the potential causes of the CopyState situation described above:

¢ You synchronized two folders using programs other than GoodSync.
¢ You deleted file on one side manually and it was deleted on another side already.
¢ You did Reset State in GoodSync.

Sync State action

If file is the same on the left and right side of the sync but the stored state of the file is not the same then
GoodSync would recommend a special Sync State action for such files.

The results of the Analyze step will inform you that Sync State will be done, if this is necessary.
You cannot change direction of Sync State action, as it is not directional action.
The following are the potential causes of the CopyState situation described above:

¢ You synchronized two folders using programs other than GoodSync.

¢ You copied files manually.
¢ You did Reset State in GoodSync.

No Copy action

This action tells GoodSync not to do anything for this pair of files, because files are the same on both
sides.

Error action
The file or folder cannot be read, see status area for details.
Conflict action

If you changed the file on both sides of the synchronized folder pair then GoodSync cannot determine
which version is preferred (because it does not know which set of changes should win and which should
be dropped) and GoodSync then declares a conflict.

By default, conflict is a no-copy action. But you can change conflict into LeftToRight or RightToLeft Copy,
thus declaring one side a winner.

Types of Conflicts

GoodSync may produce these types of conflicts:



¢ Modified On Both Sides.
Description: File was modified or deleted by user both on the left and right side.
Type: resolvable conflict, user may select sync direction.
¢ Vertical Delete - Change Conflict.
Description: User deleted folder on the left (right) and modified or deleted files in this folder on the
right (left).
Type: resolvable conflict, user may select sync direction.
e Case Conflict.
Description: items (files or folders) on one side differ only by case.
Type: resolvable conflict, user may select sync direction so that only one spelling variant remains.
¢ File vs Folder.
Description: the same relative path leads to a file on one side and folder on another side.
Type: unresolvable conflict, user must rename or delete item on either side to fix this collision.
e Expected Sync Direction Violated.
Description: 1-way Verified job produces this conflict if file or deletion will be propagated Left or
Right while user setup 1-way job to be Right to Left, or vice versa. Happens if destination side of
1-way backup job is modified.
Type: resolvable conflict, user may select sync direction.

Managing Time Shifts

FAT file system still used in Windows and some FTP servers have these problems:

¢ Local file modification time is stored, so moving between time zones makes your file modification
shift.

¢ Modification time is stored with only 2 sec precision in FAT, so copying a file to FAT may give ita
slightly different modification time. GoodSync ignores differences of +- 2 sec in modification time.

GoodSync recognizes two types of Time Shifts:

¢ Old-New Time Shift: Current file modification time differs from stored modification time by whole
number of hours for a considerable number of files. Corrected by storing new modification time on
the next Sync.

¢ Left-Right Time Shift: File on the Left and Right have a whole hour difference in modification time
for a considerable number of files. This time shift is turned into Copy Time action.

Back to the Top

Icon Descriptions

File Actions

System action: file will be copied to the right side.
User override: file will be copied to the right side.

System action: file will be deleted on the right side.

% % V9

User override: file will be deleted from the right side.
<0 System action: file will be copied to the left side.

<30 User override: file will be copied to the left side.



a1 b
S

™
N

System action: file will be deleted from the left side.

User override: file will be deleted from the left side.

Folder Actions

O 5p  Afolder will be created on the right side.
@ 0¥ Afolder will be deleted on the right side.
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A folder will be created on the left side.
A folder will be deleted on the left side.

Special Actions

#0dF  Copy time stamp but not the file itself from the left to the right side.

a1
S

50 of

[y ™
S

Copy time stamp but not the file itself from the right to the left side.
Copy internal GoodSync "file state" from the left to the right side.
Copy internal GoodSync "file state" from the right to the left side.

Central Column
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ltem is in sync.
User set this item action to No Copy.
ltem is excluded. See the status column for exclude reason.

Conflict. GoodSync can not decide how to sync this item, likely because item was
modified on both sides. See the status column for details.

Error. GoodSync can not sync this item. See the status column for explanation.

ltem is currently synchronizing.

Job Icons

2

'2?'

Job is not analyzed.

Job is waiting to start.

Job has been paused during analysis or sync.

Job is being analyzed.

Job analysis has been completed, GoodSync is now ready to synchronize.
Specified job is in the process of being synchronized.

Specified job has been synchronized.

User attention is required after analysis or synchronization has been completed.

Error starting a job.

Job Direction

&
3

4

Two-way job.
One-way "Left" to "Right" Job.
One-way "Right" to "Left" Job.
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Advanced Topics
Portable Paths

You can specify a portable path in the left or right sync folder like so:
=VolumeName:\folder1\folder2

Here VolumeName is volume label that you can set in volume properties in the Windows Explorer.

If path is specified in the portable format, GoodSync will look for a volume named VolumeName in all
portable (removable) drives attached to this computer.

So if this volume gets a different drive letter next time you insert it, GoodSync will still be able to find it.

When you select a folder on a removable drive in the Browse dialog,
GoodSync will offer to record path to this folder in the portable path format.

When you select a folder on GoodSync2Go folder from which you started GoodSync2Go,

drive letter will be automatically replaced with %GSDISK%.

So no matter what computer plug in your removable drive into and no matter what letter you drive gets,
GoodSync2Go will find its sync folders, as they will be on %GSDISK% drive.

Related topics:
* Computer Specific Paths are used to refer to a path that is valid only for one computer.
* %GSDISK% can be used in Scripts tab program, then the program is run from the GS2Go disk.

Environment Variables in Paths

You can use any Windows environment variable in folder paths, inserted like so: %VARIABLEY%
Environment variable can be put in only by directly editing the folder path, not via Browse dialog.

Popular environment variables are:
%GSDISK% - disk from which GoodSync.exe was started such as C: or F:.
Use this to refer to folders stored on GoodSync2Go volume, in Portable version.
%USERNAME% — current window user name
%USERPROFILE% — current user profile directory.
%COMPUTERNAME% - windows name of this computer.

Also GoodSync substitutes these special variables:
%YYYY% — current year.

%MM% - current month, from 01 to 12.

%DD% - current day of the month, from 01 to 31.
%DOW% - current day of the week, from 1to 7.
%WOM% - current week of the month, from 1 to 4.

Case Sensitivity

GoodSync uses case-sensitive file and folder names.

That s, for GoodSync Folder\File txt is different from FOLDER\file. TXT.



Windows historically maintains a case-insensitive file system, that is, Folder\File.txt will be the same path
as FoldeR\file.TXT. However, Windows preserves case, so if you rename File txt to file. TXT, it sticks.

In the modern Internet centric world you often have to synchronize or exchange files with UNIX-based
servers and Mac OS (now UNIX too) computers. Most FTP, SFTP and WebDAYV implementations are
case-sensitive. Also it would be nice to have all file and folder names spelled exactly the same, even on
Windows.

So given these circumstances we made a decision to enforce case sensitivity in GoodSync.
Job Templates

Job Template is an incomplete Job, usually with right folder not set. It is used to save your favorite set
of Job options as a Template, so that other Jobs can be easily created from it.

To create a Template from a Job, go to this Jobs and select Job -> Save as Template.
To create a new job from a saved template, select Job > New.

In the New Job dialog, select From Template option. Then select the template from which Job should be
created.

Back to the Top

Filters: Exclusions and Inclusions

By default GoodSync synchronizes all files and folders that are not hidden and not system.

Hidden and system files can be synchronized too, if option to exclude them is turned off.
Exclude Filter

You may want to exclude some files and folders from synchronization by using Exclude filter.
For instance, object files *.OBJ and editor backup files * BAK are usually excluded.

The easiest way to exclude the file or group of files is to perform Analyze and then right-click the file or
folder and select one of the Exclusion commands:

¢ Exclude '/FolderName/FileName' file or folder:

Exclude only this file or folder, as specified by its complete path '/FolderName/FileName'.
e Exclude All 'ltemName’ files or folders:

Exclude all files or folders (in any of subfolders) that are named 'temName’'.
e Exclude All "*.ext' files:

Exclude all files that have extension 'ext’, in all sub-folders.

Exclusion command adds a line to the list of exclusions in Jobs -> Options -> Filters -> Excluded.
This tab is the only place where you can modify or delete exclusions.

For details see this tab description in Job > Options -> Filters.

Global exclusions that apply to all jobs can be set in Tools -> Program Options -> Filters.

(1) Line that starts with "/ matches file or folder path (which is relative to the sync folder).
Exact match is required, no ™' or '/' expansion characters are allowed.



Addition of '/' or '/*' to the string does not change the match results.

Examples:

ffolder1/file2.ext — matches file2.ext in folder /folder1,

ffolder1 — matches folder /folder1 and all files and folder contained in it.
ffolder1/ or /folder1/* — still matches folder /folder1 and all files and folder in it.

(2) Line that starts with "path " matches file or folder path (relative to sync folder)
to wildcard match string in which:

* means any sequence of characters except/

? means an arbitrary single character

| separates folders

Examples:
path /folder1/file2.ext — matches file by its path,
path /AI* — matches top level folders that start with Al

(3) Line that starts with "name " matches file or folder name (last member of the path)
to wildcard match string in which:

* means any sequence of characters except/

? means an arbitrary single character

/is not allowed

Examples:

name *xls — Excel files,

name *bak — backup files of text editor,

name *kiss* —files that contain "kiss" in their name

(4) Lines that start with "any size" or "all size" allow exclusion of files by file size:

any size<N

means size left<N OR size right<N
all size<N

means size left<N AND size right<N
any size>N

means size left>N OR size right>N
all size>N

means size left>N AND size right>N
any size=N

means size left=N OR size right=N
all size=N

means size left=N AND size right=N
any size!=N

means size left!=N OR size right!=N
all size!=N

means size left!=N AND size right!=N
any size>=N

means size left>=N OR size right>=N
all size>=N

means size left>=N AND size right>=N
any size<=N

means size left<=N OR size right<=N
all size<=N

means size left<=N AND size right<=N



any size[S1,S2]

means S1 <= size left < S2 OR S1 <= size.right < S2
all size[S1,S2]

means S1 <= size left < S2 AND S1 <= size.right < S2
where N is a number, possibly with K (Kilo) or M (Mega) suffix.
No spaces is allowed in the "size" match line.

Examples:

all size>=100 - files on both sides contain 100 bytes or more

any size<2K - files that contain less than 2,048 (1K = 1024) bytes on either left or right side

all size=3M —files that contain exactly 3,145,728 bytes (1M = 1024 * 1024 ) bytes on both sides

(5) Lines that start with "any time" or "all time" allow exclusion of files by modification date:
any time<T
means time left<T OR time.right<T

all time<T

means time left<T AND time right<T
any time>T

means time left>T OR time right>T
all time>T

means time left>T AND time right>T
any time=T

means time left=T OR time right=T
all time=T

means time left=T AND time right=T
any time!=T

means time left!=T OR time right!=T
all time!l=T

means time left!=T AND time.right!=T
any time>=T

means time left>=T OR time right>=T
all time>=T

means time left>=T AND time right>=T
any time<=T

means time left<=T OR time right<=T
all time<=T

means time left<=T AND time right<=T
any time[S1,S2]

means S1 <= time left < S2 OR S1 <= time right < S2
all time[S1,S2]

means S1 <= time left < S2 AND S1 <= time right < S2

Where T is date in one of these formats:
YYYY/MM/DD - year/month/day

-Nd — N days ago

+Nd — N days in the future

No spaces is allowed in the "time" match line.

Examples:

any time>=2008/7/4 —files modified at 00:00 on July 4, 2008 or later on either side
all time<-5d —files older than 5 days ago on both sides

time>=+7d —files modified 7 days in the future or later on either side



(6) Lines that start with "is" match file and folder attributes:
isfolder or <subfolder>

matches a folder
isfile

matches a file
issymlink

matches symbolic link or junction
ishidden

matches files and folders with hidden attribute
issystem

matches files and folders with system attribute (Windows only)
isarchive

matches files and folders with archive attribute (Windows only)
isreadonly

matches files and folders with readonly attribute (Windows only)
isoffline

matches files and folders with offline attribute (Windows only)
iscompressed

matches files and folders with compressed attribute (Windows only)
isencrypted

matches files and folders with encrypted attribute (Windows only)

By default GoodSync excludes hidden and system files and folders, because these files are not user
files and usually they are not worth backing up or syncing. If you want GoodSync to see these files,
uncheck "Exclude Hidden Files" and "Exclude System Files" in Job -> Options -> Filters.

(7) Lines that start with "exist" match facts of presence and absence of file and folders.
existhboth

file or folder exists both on left and right side
existone

file or folder exists only on one side

(8) Lines that do not have any of the above prefixes are interpreted as file names if they do not contain
'"and as file paths if they contain '/'.

Exclude Composition. There is an implicit OR between lines of the Exclude filter.

Each line can contain more than one clause separated by semicolon";".
There is an implicit AND between clauses in the exclude line.

Example: filter

ishidden; name *bak; all time <-60d

all size<1k
matches hidden files that have bak extension that are older than 60 days on both sides or files whose
size on both sides is less than 1024 bytes.

Any and All qualifiers. File modification times may be different on Left and Right, then
you have to use "any" or "all" qualifier to get the desired result.

Example: exclude filter 'time<-30d' is true for all files

where 'left time < tNow - 30d OR right time < tNow - 30d".

So if you want to exclude all files older than 30 days (on both sides that is),

you should use exclude line 'all time<-30d' which is

the same as 'left time < tNow - 30d AND right time < tNow - 30d'".



Include Filter

Include Filter includes only files and folders specified in it and it excludes everything else.
Include Filter is applied before the Exclude Filter.

Include Filter is set in Jobs -> Options -> Filters -> Include.
These are the popular Include filters and context menu items that add them:

* Include Only '/FolderName/FileName' file or folder.

Include only this file or folder, as specified by its complete path '/FolderName/FileName'.

You can select several files and folders (multi-select is done by clicking items while holding CTRL key)
and then they all will be added to the Include list.

* Include Only ™.ext' files.

Include only files that have extension 'ext', in all sub-folders.

Note that if an *.ext line is present in the Include filter then all folders that contains such files are included
too,

because GoodSync must include a folder if it includes a file within this folder.

Special "size" and "time" matches work in the Include filters too.

Include Composition. There is an implicit OR between lines of Include filter.

Each line can contain more than one clause separated by semicolon";".
There is an implicit AND between clauses in the line.

If both Exclude and Include filters are specified then the Include filter is used first, then Exclude filter is
applied to the Include results.

More specifically, Exclude Filter of
ExcludeLine1
ExcludeLine2
ExcludeLine3
and Include Filter of
IncludeLine1
IncludeLine2
IncludeLine3
computes as
( IncludeLine1 OR IncludeLine2 OR IncludeLine3 ) AND
NOT ( ExcludeLine1 OR ExcludeLine2 OR ExcludeLine3 )

Back to the Top

Commands and Keyboard Shortcuts

This describes GoodSync commands that can be started by clicking buttons and selecting menu items.
Job commands

Job -> New Alt+N

Create New Job. First job is created automatically when you start GoodSync for the first time.
GoodSync asks user to create the first job.



Job -> Delete Alt+D
Delete this Job.

Job -> Rename... Alt+M
Rename this Job.

Job -> Clone... Alt+C
Clone this Job. That is, create a new job with a different name that is a copy of this job.

Job -> Swap Job Sides
Swap Left and Right folder in this Job.

Job -> Save as Template
Save this job as a template. Templates can be used when creating a New Job.

Analyze button or Job -> Analyze Alt+A F5
Analyze this Job. Show proposed changes.

Job -> Analyze All F6
Analyze all Jobs.

Sync button or Job -> Synchronize Alt+S F7
Synchronize this Job. Execute (commit) changes that Analyze has proposed.

Job -> Synchronize All F8
Synchronize all analyzed Jobs.

Job -> Analyze and Synchronize Alt+Y F9
Analyze and then Sync this job.

Job -> Analyze and Sync All F10
For all jobs: Analyze and then Sync each job.

Stop button or Job -> Stop AIlt+T ESC
Stop analysis or synchronization of this Job. Also cancel ready-to-un status for other jobs.
Sync can be continued after Stop.

Job -> Stop All
Stop analysis or synchronization for all jobs that are running.

Pause / Resume button
Pause / Resume analysis or synchronization of this Job.

Job -> List of Changes Alt+l
Show printable list of changes. Works after Analyze, when changes become available.

Job -> Open Left Log File Alt+L
Open log file for the Left folder of this job. Logs records all actions that all GoodSync jobs have done to
this folder and its sub-folders.

Job -> Open Right Log File Alt+R
Open log file for the Right folder of this job. Logs records all actions that all GoodSync jobs have done
to this folder and its sub-folders.

Job -> Options Alt+O



Show Options dialog for this Job.

Job -> Delete History (Recycle Bin)

Delete previous versions of files (Recycle Bin) that GoodSync saves in _gsdata_\ saved_ folder per
"Save Previous Version of Deleted/Replaced File" option.

Also delete all files in _gsdata_/ history_folder where historic file versions are saved.

Job -> Reset State
Delete GoodSync state files on both sides of this Job. Causes GoodSync to forget state info. Do not use
this command unless directed by Support.

Job -> Exit Alt+X Alt+F4
Exit GoodSync.

Job Selection

Click Tab Alt+1 to Alt+9
Select another job, make it current (referred to as This Job). Most commands in Job and Tree menu
apply to the current job.

View/Hide Panels commands

View -> Job List
Show/Hide Job List pane. This pane shows time when the job last ran and current status of the job. Not
shown by default.

View -> Filters
Show/Hide Filters pane. It shows all Exclude and Include filters for this Job. Not shown by defaullt.

View -> Log
Show/Hide Log pane. It shows automatically scrolled log for this Job. Shown by defaullt.

View -> Status Bar
Show/Hide Status Bar. Shown by default.

Tree View commands

All button or View -> All
Show Al live files and folders, that is, items not deleted on both sides.

Changes button or View -> Changes Alt+G
Show Changes, that is, only files and folders that are different and to which Copy File command will be
applied.

Conflicts button or View -> Conflicts Alt+F
Show Conflicts, that is, files that were changed on both sides of the Job.

Errors button or View -> Errors Alt+E
Show Errors that occurred during Analyze or Sync. Errors are not conflicts, they are usually originated
by file system. Example: file is locked, cannot drill into folder.

Other -> Included or View -> Other -> Included
Show files and folders that are include in the Analyze. That is, not excluded by Exclude/Include filters.



Other -> Excluded or View -> Other -> Excluded
Show files and folders that are excluded by Exclude/Include filter.

Other -> New or View -> Other -> New
Show New files and folders. That is, files and folders that exist on one side and do not exist on the
other side and copy action will copy them to this other side.

Other -> Overwrite or View -> Other -> Overwrite
Show files that will be Overwritten. That is, files that exist on both sides and copy action will copy file
from one side to another.

Other -> Delete or View -> Other -> Delete
Show files and folder that will be Deleted. That is, files and folders that exist on one side and do not
exist on the other side and copy action will delete them on this other side.

Other -> Left to Right or View -> Other -> Left to Right
Show files that will be copied from Left to Right by Copy File action.

Other -> Right to Left or View -> Other -> Right to Left
Show files that will be copied from Right to Left by Copy File action.

Other -> Copy Time L to R or View -> Other -> Copy Time Lto R
Show files that whose modification time will be copied from Left to Right by Copy Time action.

Other -> Copy Time R to L or View -> Other -> Copy Time Rto L
Show files that whose modification time will be copied from Right to Left by Copy Time action.

Other -> Copy State L to R or View -> Other -> Copy State L to R
Show files that whose state will be copied from Left to Right by Copy State action.

Other -> Copy State R to L or View -> Other -> Copy State Rto L
Show files that whose state will be copied from Right to Left by Copy State action.

Other -> Sync State or View -> Other -> Sync State
Show files that whose states will be synced without copying files themselves.

Other -> SameLength DiffTime or View -> Other -> SameLength DiffTime
Show files that exist on both sides, have the same length but different modification time.
These are candidates for Copy Time action, if you believe that files are actually the same.

Other -> All Live + Dead or View -> Other -> AllLive + Dead
Show both existing files and files that were previously deleted.

Tree Expand commands

These commands are available through keyboard shortcuts and are standard for Windows trees.
Gray '+' means '+' key on the numeric side keyboard.

Gray +
Open one level of the tree. Focus must be on the node to open.

Gray -
Close one level of the tree. Focus must be on the node to close.



Gray *
Open all levels of the tree starting from here. Focus must be on the node to open.

Action commands

All Action commands are also available from file or folder context menu.

Action -> Open Left File
Open file on the Left.

Action -> Open Right File
Open file on the Right.

Action -> Delete Left File
Delete file on the Left.

Action -> Delete Right File
Delete file on the Right.

Action -> Delete Both Files
Delete file on the Left and on the Right.

Action -> Compare Left to Right
Compare file on the Left to file on the Right using compare diffdike program
defined in Tools -=> Program Options -> File Compare program.

Action -> Exclude ‘\..." File
Exclude this file from Analyze.

Action -> Exclude All"..." Files
Exclude all files that have the same name as this file, but maybe sit in other folders.

Action -> Exclude All "*.ext' Files
Exclude all files that have extension .ext, in all folders.

Action -> Include All "*.ext' Files
Include only files that have extension .ext, in all folders.

Action -> As Recommended
Set action to what was recommended by Analyze. Enabled only after you modified action proposed by
Analyze.

Action -> Left to Right
Set action to Copy File Left to Right.

Action -> Right to Left
Set action to Copy File Right to Left.

Action -> Do Not Copy
Set action to No Copy.

Action -> Copy Time Left to Right
Set action to Copy Time Left to Right.



Action -> Copy Time Right to Left
Set action to Copy Time Right to Left.

Tools commands

Tools -> Program Options
Show Global Program Options dialog.

Tools -> Import from V4
Import jobs from GoodSync V4.

Tools -> Export Job List
Export job list (all jobs, or only jobs selected in Job List pane) to *.gsl file.

Tools -> Import Job List
Import jobs from *.gsl file. Imported jobs are added to the existing jobs.

Help commands

Help -> Manual
Show this Online Manual from www.goodsync.com.

Help -> FAQ
Show Online Frequently Asked Questions from www.goodsync.com.

Help -> Buy Pro
Buy GoodSync Pro version from www.goodsync.com.

Help -> Activate Pro
Activate GoodSync Pro after you purchased it. You will need Order ID and your name as it appears in
the Order.

Help -> Create Support Ticket
Create ZIP file that contains job logs and other technical info. Attach this ZIP file to Support Ticket that
you open in GoodSync Online Support System (GSSS) at supportgoodsync.com.

Help -> Check for Updates
Check for new GoodSync version at www.goodsync.com. GoodSync also automatically checks for its
new version upon start.

Help -> About...
Show About dialog with credits and version info.

Back to the Top

File Systems: Local and Remote

GoodSync can synchronize not only disk and net shares mounted on your computer. It can also
synchronize with Remote File Systems (FS) accessible through these protocols: FTP, Secure FTP
(SSH), WebDAV.

To select or change your sync folder, click Browse button on the left or right side of Sync.
The Browse File System dialog appears.



File System Type appears in the left navigation pane of the Browse dialog.
To change File System Type, click on different file systems on the left.

Then enter or edit your Remote Server Address in Address field (Remote FS only).

Then enter UserlD, Password and maybe other connection data (Remote FS only).

Then click Go button to connect to the server and test whether the data you entered is correct.

If connection is successful, the Home Folder of UserID you used is shown and all folders above it.
Navigate to the folder to sync with in the folder tree.

If folder you want to sync with does not exist, create it:
navigate to its parent folder and click Make New Folder button.

Below we provide detailed description of Local and Remote File Systems that GoodSync supports.
My Computer / Windows File System

Disks mounted directly on this computer.
Naming convention used: Windows "disk letter + path", example: C:\folder1\folder2\file.ext
Plus two other naming conventions for Portable and Computer Specific paths, see below.

Since no authentication is required and disks are always connected, the folder tree is shown right away
(clicking Go button is not needed).

Portable Path (ver 7.8.2 and higher)

You can specify the disk by its volume name, like so:

=VolumeName:\folder1\folder2

Here VolumeName is volume name that you can set in volume properties in the Windows Explorer.
Use it to designate removable volumes that can be mounted to different disk letters.

Computer Specific Path (ver 8.1.0 and higher)

You can specify the path that works only on designated computer, like so:
\\=ComputerName\x:\folder1\folder2

This path will only be found on computer named ComputerName.

Use computer specific paths in GoodSync2Go, where the same jobs will run on different computers and
you want some jobs to run only on specific computers, not on all computers.

Encrypt/Decrypt Files using Encrypting File System

You can encrypt and decrypt files using Windows Encrypting File System (EFS).

GoodSync will encrypt files on the side where Encrypt Using EFS option is specified.

GoodSync will decrypt files on the side where Decrypt Using EFS option is specified.

Note that EFS works only on NTFS volumes and not on FAT volumes.

EFS is not supported on Windows XP Home, Windows Vista / 7 Starter, Windows Vista / 7 Home Basic,
and Windows Vista Home / 7 Premium. You must have at least Windows XP Pro, Windows Vista / 7
Business, Windows Vista / 7 Ultimate, or Windows Vista / 7 Enterprise.

Compress Files in NTFS

You can compress and uncompress files using Windows NTFS compression ability.
GoodSync will compress files on the side where Compress in NTFS option is specified.
GoodSync will uncompress files on the side where Uncompress in NTFS option is specified.



Palm and Other USB Mass Storage Devices

These days Palm, Treo and many devices may present themselves as a regular Windows File System
using USB Mass Storage Devices interface. Most Palm OS devices produced in the last 34 years can
do that.

So if you have a Palm or Treo phone or PDA, you can sync its files with Windows desktop using
GoodSync. Sync with Palm/Treo disk mounted to your Windows desktop, it will appear in My Computer
tab.

Music and Media Players
You can also sync with Music and Media Players that show themselves as a Portable Disk using USB
Mass Storage Devices interface. Such devices will also appear in My Computer tab.

My Network / Windows Net Shares

Net Shares (remotely mounted disk volumes) available through Microsoft networking.
Naming convention used: Windows UNC, example: \\share\disk\folder1\folder2\file ext

List of available network shares is shown, then you can drill down to the sync folder.

Enter UserID and Password if your share is password-protected by UserID and Password that is
different from UserID and Password of the Windows account you are logged in to.

You can mount shares both from Local Network (LAN) and from remote computers (WAN), see
Synchronizing Via Network section below.

Note that once you logged in to Share, Windows will cache authentication data. So if authentication data
changes on server, you must Logout and then Login to you account on the client to make Windows use
new authentication data.

FTP

Remote FTP server.

Naming convention: URL with ftp// or ftps// prefix, example:
ftp//serverdomain.com/folder1/folder2ffile ext

Extended naming convention adds port, auth data:
ftp//userid:password@server.domain.com:port/folder/file

UserID and Password are usually required.
If UserlD and Password are empty, GoodSync uses UserID "anonymous" and Password
"gsuser@someplace.com"”

Secure mode (FTPS): Explicit and Implicit

By default your UserID, Password and data are not encrypted when transferred between your client
and FTP server. However if your FTP server supports FTPS (FTP over SSL) then you can encrypt your
FTP transfer. Check Secure Mode box under Browse button and URL prefix will change from ftp:// to
ftps// which means that GoodSync will try to establish encrypted FTPS connection to the FTP server.
FTPS has two modes: Explicit and Implicit. Explicit is the default and recommended mode.

In Explicit mode GoodSync negotiates with the server about what encryption to use.

In Implicit mode the connection to server is open in SSL mode right away (on port 990) without any
negotiation.

Do not Check SSL server certificates
If Secure Mode is ON and this checkbox is unchecked then GoodSync will check FTP SSL server



certificate: that certificate is on a trust chain that starts with known Certificate Authority, that certificate is
not expired, that sever name (common name) in the certificate is exactly the same as server name you
are connecting to.

If this box is checked then none of these checks are performed. Check the box if you are using self-
signed certificate or care only about encryption and not about verification of the server identity.

UTF-8 file name encoding.

FTP is a byte protocol, so encoding non-ASCII (hondatin) characters can be done in several different
ways.

An original way to encode was ANSI encoding, where ASCII codes from 128 to 255 were used to
encode accented characters. Apparently this could work in very limited circumstances where both client
and server agree on the same meaning of ASCIl codes from 128 to 255, which usually means that client
and server are both language specific and they cater to the same language.

A better, more modern way is to use UTF-8 encoding that can encode any UNICODE character. Unlike
ANSI encoding, UTF-8 encoding does not depend on any offthe-books agreement between client and
server.

Connect Via Proxy
If this box is checked then GoodSync will connect to FTP server
via HTTP-style proxy specified in Tools - Program Options -> Connections.

Active Mode or Passive Mode.

By default GoodSync uses Passive FTP mode when connecting, because in this mode no data
connections from server to client are required and these connections are not allowed by most firewalls.
Check Active Mode box only if Passive mode connection is not allowed by server and if you firewalls
allow servers to initiate FTP data connection to the client.

Implicit FTPS.
See Secure Mode explanation.

Use MDTM to get Exact File Modification Time.

By default GoodSync gets file modification time from file listing. In this listing file modification time will be
rounded to the nearest minute or even day and this may create fake changes.

if MDTM (GET) command is available, then GoodSync can get exact down-to-the-second file
modification time, but Analyze will take more time.

if MDTM (SET) command is available, then GoodSync will use it to set correct file modification time on
server.

Note that newer MFMT is used instead of MDTM set command, if available on server.

Ping Control Connection.

If checked then GoodSync pings control socket connection while long download or upload is running on
data connection. GoodSync sends NOOP command to control connection every 60 seconds when data
connection is active, so that routers and firewalls do not think that control connection is inactive and
terminate it. If not checked, then only TCP Keep-Alive option is used to keep the control connection up. In
most circumstances TCP Keep-Alive is sufficient and you should not check this box.

WebDAV

Remote WebDAV server.

Naming convention: URL with http:// or https// prefix, example:
http//server.domain.com/folder1/folder2/file ext

Extended naming convention adds port, auth data:



http//userid:password@server.domain.com:port/folder/file
UserID and Password are always required.
DAV is an upload-enabled extension of HTTP protocol.

Some folders on the server may be HTTP only and some folders will allow DAV uploads. This means
that you must type the full path to your DAV folder, you cannot type in just server name, click Go and
drill down to the DAV folder. This happens because top folder of the HTTP server is usually not DAV
enabled and it will not list folders inside it for security reasons.

If you are given only HTTP read access to folder and no DAV access then you can see this folder in a
browser, but you cannot see or modify it in GoodSync DAV.

Secure mode (SSL)

By default your UserID, Password and data are not encrypted when transferred between your client
and DAV server. However if your HTTP server supports SSL (most do) then check Secure Mode box
under Browse button and URL prefix will change from http:// to https:// which means that GoodSync will
establish encrypted SSL connection to the server.

Do not check SSL server certificates

If Secure Mode is ON and this checkbox is unchecked then GoodSync will check SSL server certificate:
that certificate is on a trust chain that starts with known Certificate Authority, that certificate is not
expired, that sever name (common name) in the certificate is exactly the same as server name you are
connecting to.

If this box is checked then none of these checks are performed.

UTF-8 Encoding. (Always On)
Non-atin characters are always encoded using UTF-8 in WebDAV.

Connect Via Proxy
If this box is checked then GoodSync will connect to the server
via HTTP-style proxy specified in Tools -> Program Options -> Connections.

Send Cookies to Server. (Off by default)
Check this option if you want our DAV client to send cookies to DAV server. Most servers do not need
cookies, as they have authentication in every request.

Amazon S3

Amazon S3 server.
Naming convention: URL with http://s3.amazonaws.com or https://s3.amazonaws.com prefix, example:
http://s3.amazonaws.com/bucket/folder/file ext

S3 is a variation of WebDAV protocol, a relative of HTTP protocol.
AWS Access Key ID and AWS Secret Access Key are always required.

Put your AWS Bucket Name into the top folder of the URL, like so:
http://s3.amazonaws.com/bucket/folder/file ext

Note: these Amazon S3 rules (however arbitrary or unobvious) must be followed:
(i) In host-based addressing (option under Browse > Advanced) bucket names must be lower case and
they can consist only of letters and digits. No upper case of mixed case bucket names are allowed.



(i) In URL-based addressing (host-based addressing is Off) bucket names can be mixed-case.
(iii) All European, Asian and other non-US buckets must use host-based addressing, which means that
they must have lower-case names.

GoodSync File and Folder Model:

S3 does not have a notion of folders and files, they have buckets, keys and values. Therefore folders
and files model has to be translated to buckets, keys and values model and different programs do itin a
different way.

GoodSync model is rather straightforward:

(i) folder is a key whose name is folder path that ends with '/ and content is empty.

(i) file is a key whose name is path of the file and content is content of the file.

(iii) bucket is top level folder.

GoodSync and other S3 clients:

Folders and files that GoodSync create may be not recognized by other S3 client programs that use
different model. Therefore you should create and use folders only with GoodSync and other programs
that support the same model.

Secure mode (SSL)
Check Secure Mode box and URL prefix will change from httpz// to https:// which means that GoodSync
will establish encrypted SSL connection to the S3 server.

Do not check SSL server certificates
If Secure Mode is ON and this checkbox is unchecked then GoodSync will check SSL server certificate.
Since Amazon S3 server has valid certificate, keep this box always checked if using Secure Mode.

UTF-8 Encoding. (Always On)
Nonatin characters are always encoded using UTF-8 in S3.

Connect Via Proxy
If this box is checked then GoodSync will connect to the server
via HTTP-style proxy specified in Tools -> Program Options -> Connections.

Host-based Addressing for Buckets

If checked then use host-based addressing for buckets.

Must be checked for buckets hosted in Europe.

Host-based bucket names may contain only lower case latin letters and digits.
If unchecked then use URL-based addressing for buckets.

Access Control (empty by default)

Amazon S3 Access Control Policy, can be one of Canned Access Policies:
private (default), publicread, publicread-write, authenticated-read.

All uploaded files are uploaded with the specified policy.

Secure FTP (SFTP)

Remote SSH server with SFTP capability.

Naming convention used: URL with sftpi// prefix, example:
sftp//serverdomain.com/folder1/folder2/ffile ext

Extended naming convention adds port, auth data:
sftp://userid:password@server.domain.com:port/folder/file
Works only with SSH-2 servers, not with SSH-1 servers.



Authentication data is always required, and it comes in two different varieties:

* UserlD + Password.
Just like in FTP, UserID and Password are required to log in.

* UserID + Private Key File ( + Password ).

Private Key File is a small (1-2 Kb) file that contains the "private key" part of the Public - Private Key Pair.
The Public Key is located on the server and only server administrator can put it there.

Private Key may additionally be protected by a password. Enter this password into the Browse dialog
or use private key caching program such as Pageant.

You can also specify 'PuTTY Session' in GoodSync ver 7.7.0 or later.
Then GoodSync takes settings from PuTTY session you specified and
applies to them all other settings the from Browse dialog.

This way you can specify SFTP proxy and more connection options.

Private Key format: we use PuTTY private key format that looks something like this:

PuTTY-User-Key-File-2: ssh-rsa

Encryption: aes256-cbc

Comment: [1024-bit rsa, First Last@computer, Wed Jun 04 2003 23:28:59]
Public-Lines: 4
encodedpublickeyencodedpublickeyencodedpublickeyencodedpublickey
encodedpublickeyencodedpublickeyencodedpublickeyencodedpublickey
encodedpublickeyencodedpublickeyencodedpublickeyencodedpublickey
encodedpub==

Private-Lines: 8
encodedprivatekeyencodedprivatekeyencodedprivatekeyencodedprivat
encodedprivatekeyencodedprivatekeyencodedprivatekeyencodedprivat
encodedprivatekeyencodedprivatekeyencodedprivatekeyencodedprivat
encodedprivatekeyencodedprivatekeyencodedprivatekeyencodedprivat
encodedprivatekeyencodedprivatekeyencodedprivatekeyencodedprivat
encodedprivatekeyencodedprivatekeyencodedprivatekeyencodedprivat
encodedprivatekeyencodedprivatekeyencodedprivatekeyencodedprivat
encodedprivatekeyxxxxx==

Private-MAC: abXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXb3a

Secure mode (Always On)
In SFTP protocol all communication is encrypted.

UTF-8 file name encoding.

SFTP is a byte protocol too, so encoding non-ASCII (hondatin) characters has the same issues as FTP.
In this option you can select ANSI or UTF-8 encoding.

UTF-8 encoding is recommended and is the default.

See FTP for more details.

PuTTY session.

GoodSync SFTP implementation is based on PuTTY code.

PuTTY has a plenty of connection options, especially for proxies.

You can use all these options by specifying PUTTY session name.

Please note that PUTTY itself does not have to be installed, GoodSync will just use PuTTY session
settings from registry.

Private Key.
See explanation above.



Windows Mobile Phone and Pocket PC

Windows Mobile phones and Pocket PC devices.
Naming convention used: URL with wm: prefix, example: wm:MyPhone\My RoboForm Data

Device should be physically connected to the computer, usually it is plugged into USB port.
ActiveSync or Windows Mobile Device Center (WMDC) must be installed on the desktop.

Device is not required to have a partnership with desktop on which GoodSync runs.

So you can sync phone files with more than two desktops.

To sync with the phone that has no "relationship" with your desktop: when ActiveSync tells you to create
a new relationship upon connecting your phone to the desktop, select Guest Relationship or just press

Cancel.

Back to the Top

Job Options
Each Job has a set of options that modify the behavior of synchronization algorithm for this job.
General tab

Sync Direction
Synchronization direction can be one of the three choices below.

2-Way
(default value)
Propagate changes from Left to Right and propagate changes from Right to Left.
1-Way Left to Right
Propagate changes only from Left to Right.
1-Way Right to Left
Propagate changes only from Right to Left.

This modifier applies both to 2-way and 1-way syncs:

Propagate Deletions (checked by default)
If checked, then deletion made by user on one side of the job is propagated to the other side of the job.
If not checked, then deletions are not propagated, only newer files are propagated.

There are several modifiers that apply only to 1-way syncs:

Forced Copy

(default for 1-way jobs)
If selected then GoodSync will always observe the preferred sync direction, even if it results in
older files from the source side overwriting the newer files on the destination side. Use this option
to perform classic clone-style backups when you want destination folder to be an exact copy of
the source folder.

Verified Copy
If selected then GoodSync checks that files on destination side did not change and that changes



have occurred only on the source side of the job. If a change on the destination side is found, it is
declared to be a conflict.

Forced Move (Advanced)
Delete Source Files after Forced Copy. If selected then GoodSync performs Forced Copy and
after the successful Forced Copy Sync it will delete all files on the source side of the job, thus
effectively performing the file Move operation.

Read-Only Source Side
1-way Sync in which GoodSync does not write anything on the source side. All GoodSync files
(_gsdata_ folder, logs, state files) are written to _gsdata_ Mirror folder created in C:\Documents
And Settings\UserName\Application Data\GoodSync\Mirrors. This option can be used only for
folders that you have no write access to, or for folders that GoodSync never modifies.

Quick Backup Mode (Advanced)
This option has been replaced by Advanced > Fast Pre Analyze option.

Save Previous Version of deleted/replaced files (checked by default)

If checked, then GoodSync saves a file just before Sync replaces or deletes this file. The file is saved to
_gsdata_\_saved_ folder on the side where the replacement/deletion is about to occur.

Only the most recent version of the file (the one just before the current version) is retained.

Note that gsdata_ is a hidden folder, so you must check Show Hidden Files option in Windows
Explorer if you want to see contents of this folder.

Save Past Versions of deleted/replaced files (off by default)

If checked, then GoodSync saves a file just before it rewrites or deletes this file. The file is saved to
_gsdata_\_history_folder on the side where the replacement/deletion is about to occur.

Timestamp is added to file name before its extension, so that multiple versions of the file can be saved.
Directory structure is preserved.

This option overrides option Save Previous Version of deleted/replaced files.

Estimate disk space required for Sync (checked by default)

If checked then Compute how much free disk space is needed to complete the Sync.

Keep it On for jobs that write to drives with limited free space.

Turn it Off for jobs that are unlikely to overflow disks, because free space is plentiful on both sides.

Reconnect folders automatically (checked by default)
If On then GoodSync tries to reconnect the folder when folder disconnect error is detected.
If Off then folder disconnect terminates Analyze or Sync.

Number of Reconnect Attempts (3 by default)

Number of Reconnect attempts to be made, before GoodSync gives up.

There is a 30 second wait before each reconnect attempt.

Successful file operation after Reconnect causes job to continue as if nothing happened.
N unsuccessful attempts to reconnect cause job termination.

File Copy Speed Limit in KBytes/sec (0 by default)

If not zero, then limit file copy speed by the speed in KBytes/sec specified in this option.

When average file copy speed in Sync exceeds the specified threshold, GoodSync suspends (sleeps)
jobs for 1 second until the effective average speed falls below the limit.

100 Kbytes/sec is equal to approx 1 Mbit/sec.

Display Balloon messages
This option controls whether and when balloon (system tray) messages are displayed.



Never
Do not display balloon messages.
On Conflicts and Errors
(default)
Display balloon messages only when Conflicts or Errors are detected during Analyze or Sync.
On Changes and Sync
Display balloon messages when Analyze detects Changes, Conflicts or Errors.

Filters tab

Exclude (empty by default)

Files and folders that match any line on this list, will be excluded from synchronization.
Wildcards "™ and '?' can be used here, just like in Windows command line.

Matching is done with the relative file/folder path, that is, path that starts at the sync folder.
Lines that start with "\' match complete folder paths relative to sync folder.

Lines not starting with '\" will match any file name, but only relative path will be matched.

Examples:

*.0bj matched all files with .obj extension.

CVS matches all files and folder named CVS, anywhere in sync folders.

\\Folder\\*.obj matches all *.obj files located in folder Folder that appears only in root sync folders.
Folder\\*.obj matches all *.obj files located in folder Folder that appears in sync folders or their
subfolders.

Include (empty by default)
if not empty then only files and folders whose names match one of the lines of this Include list and do
not match any lines of the Exclude list, are included in synchronization.

It is recommended for the set of inclusions and exclusions to be the same for all jobs that sync with one
particular folder. Keeping them different is possible but it is likely to cause confusion as some jobs will
not sync files that other jobs would sync.

Exclude Empty Folders (un-checked by default)
If checked then Exclude folders that are empty or that contain only empty folders. Folder are
considered empty if they contain no files or if they contain only files that were excluded by Filters.

Exclude Hidden Files and Folders (checked by default)
Exclude files and folders that have HIDDEN attribute.

Exclude System Files and Folders (checked by default)
Exclude files and folders that have SYSTEM attribute.

Auto tab

Analyze and Sync can be made to run automatically by using this tab.

Check Analyze box for Analyze only to run on a specified event.
Check Sync box for Sync to run on a specified event.
If you check Sync box then Analyze box is checked too, because Analyze must be run before Sync.

One or more events may be checked to cause automatic Analyze and/or Sync:

On GoodSync start



Analyze (and maybe Sync) this job when GoodSync starts.
You can also specify delay in seconds:
when GoodSync starts, it will wait this many seconds before starting this job.

On Folders Connect

Analyze (and maybe Sync) this job when both folders of the job become connected, after they were
disconnected previously (that is, one of the folders must come from disconnected to connected state).
GoodSync checks every 3 minutes for status of left and right folders for a job with this option.

The following events speed up checking of status, as they are likely to cause folder connect or
disconnect:

* Insertion or Ejection of Portable Volume: detachable folders may connect or disconnect.

* Network Connect or Disconnect: FTP, SFTP, DAV folders may connect or disconnect

* Windows Mobile device (phone) Connect or Disconnect: Windows Mobile device connected or
disconnected.

On File Change
Analyze (and maybe Sync) this job when any file changes in left or right folder (or its sub-folder).
Only local folders are monitored (local disks and shares), not any folders on servers.

On Logoff

Analyze and then Sync this job just before Logoff from Windows.

Note that Windows may try to kill GoodSync on Logoff. Normally Windows sees that GoodSync is
performing file operations and responds to messages and it would let GoodSync finish. However this
cannot be guaranteed.

Periodically (On Timer)
Analyze (and maybe Sync) this job periodically, every HH hours and MM minutes.

Scheduled: Logged In Mode

Analyze and then Sync this job periodically, on a schedule set in Windows Task Scheduler.
Click Configure to call up Windows Task Scheduler and set schedule in it.

GoodSync will create Windows Task that would start full GoodSync.

If GoodSync does not run, it will be started as a system tray icon.

You should double-click GoodSync system tray icon to see what GoodSync is doing.

If GoodSync is already running, this job will be queued for Analyze and Sync.

You cannot use this mode to schedule run of GoodSync job when you are logged out.

Scheduled: Logged Out Mode (Unattended)

Analyze and then Sync this job periodically, on a schedule set in Windows Task Scheduler.

Click Configure to call up Windows Task Scheduler and set schedule init.

GoodSync will create Windows Task that would start GoodSync.

GSYNC.EXE will be started, which is a command line version of GoodSync.

It has no Graphical User Interface and it consumes minimal possible resources,

as there is nobody to see User Interface when users are logged out.

You can see the results of such job in logs written by GSYNC.EXE, use Job -> Open Left/Right Log Files.

You must enter Windows UserID and Password into the Windows Task, when you finish entering the
schedule of the task or when you do any changes to the task. This is what Windows documentation has
to say about it: "For security reasons, Windows will not allow you to run a task under a user account
with a blank password. Even though the Help page in Task Scheduler says a password isn't always
required."

If your Windows account has no password, you must create one in order to use Task Scheduler.

You can also check GoodSync global log (in Applications Data\GoodSync) to see whether Task



Scheduler in fact started GoodSync, if you see that job does not run when it is supposed to run.

Copy Locked Files in Unattended Mode: Vista and Windows 7 require elevation to copy locked files.
This elevation cannot happen from unattended mode, because there is no user available to respond to
elevation request. So you must set the 'Run with highest privileges' flag in the task: select Start > All
Programs -> Accessories -=> System Tools > Task Scheduler, click Task Scheduler Library on the left,
select task which starts your GoodSync job, click Properties on the right, in General tab check box 'Run
with highest privileges', in any other tab perform any change to get around Task Scheduler bug, click
OK, enter Windows account password.

On RoboForm Command
Analyze (and maybe Sync) this job when RoboForm calls for it.
To enable this option, in RoboForm select RoboForm > Tools -> Sync RoboForm Data.

Option: Do Not Sync if too many files changed (10% by default)

Automated Sync is not performed if more than the specified (in percent) fraction of files in the Job has
changed. Unusually high number of changed files indicates that something may be wrong and manual
intervention is required. Set to 100% to Sync no matter how big the changes are.

Option: Automatically Resolve Conflicts
When job is about to be Synced automatically, use this option to automatically resolve conflicts:

Do Not Copy
(default value)
Leave Conflicts in unresolved (Do Not Copy) state.
Left to Right
Resolve to Left to Right propagation.
Right to Left
Resolve to Right to Left propagation.
Newer File Wins
File with the most recent modification date wins.

You must not use this option for backup jobs, use 1-way job instead.

Option: Auto Clear on Sync or Analyze with no changes (un-checked by default)

If checked, then GoodSync automatically deletes the Changes tree after successful Sync or after
Analyze that did not detect any changes.

Deleting big Changes tree allows you to save memory. You will not be able to see sync results after
Changes tree has been deleted, because the changes are stored in the tree, but you will be able to
check sync log and see what has been done.

Auto Options work Only if GoodSync Runs

GoodSync must be already running for these Auto events to work:
- On Folder Connect

- Logoff

- Periodically (On Timer)

So you should turn on these global program options:
- Start GoodSync when Windows starts.
- Hide to System Tray when Main Window is closed.

Task Scheduler option does not require GoodSync to be running, because Windows Scheduler starts
GoodSync based on the Windows Task that GoodSync creates when you enable this option.



Job Scheduling

Each event that has just occurred flags the job as ready-to-run.

Ready-to+run jobs are run from left to right, sequentially, until all ready-to-run jobs have been run.

If job is already in the ready-to-run state and another even occurs that wants to run the job then this 2nd
event is ignored.

Back to the Top

Scripts tab

Option: Pre Analyze E-Mail or Program

If the option is not empty, then run the program specified in the option before Analyze.

Use this option to connect your folders (say, start VPN) or to otherwise prepare for Analyze.

If the program returns non-zero return code or fails then do not start Analyze (new for GS ver 8.3.2).
If the program succeeds and returns zero return code, then proceed with Analyze.

Rules for interpreting this option appear below.

If the option value contains '@', then send e-mail to address specified in the option.

Option: Post Analyze With No Changes E-Mail or Program

If the option value contains ‘@', then send e-mail to address(es) specified in the option.

If multiple email addresses are specified, they must be separated by comma or semicolon:
useri@server.com; user2@hotmail.com

If the option contains no '@', then run the program specified in the option.

Email is sent or program is run when Analyze finishes with no changes and Sync will not occur after
Analyze.

Use this option to take a custom action after Analyze With No Changes, such as disconnecting your
VPN.

Rules for interpreting this option appear below.

Option: Post Sync E-Mail or Program

If the option value contains '@', then send e-mail to the e-mail address(es) specified in the option.
If multiple email addresses are specified, they must be separated by comma or semicolon:
useri@server.com; user2@hotmail.com

If the option contains no '@', then run the program specified in the option.

Email is sent or program is run when Sync finishes. Sync follows Analyze that detected Changes.
Note that either Analyze With no Changes or Sync With Changes will happen, but not both of them.
Use this option to take custom action after Sync, such as notifying system administrator.

Rules for interpreting this option appear below.

Scripts: Calling Programs and Sending Emails

Format 1: The Pre/Post-Analyze/Sync option value specifies the arguments passed to the program:
program-name %ARG1% %ARG2% %ARG3% ...
where arguments can be one of the following (all variable names are case-sensitive):

%JOBNAME% job name
%RESULT% Result:"" for OK or "terminal error message"
%LOGPATH% Logfile pathin".."

%LF% Left folder pathin".."
%LF_ACT% Resolved (=VolumeName\folder -> f\folder) Left folder pathin "..."
%RF% Right folder pathin".."

%RF_ACT% Resolved (=VolumeName\folder -> f\folder) Right folder pathin"..."



%STAGE% Sync stage: Pre-Analyze | Post-Analyze | Post-Sync
%CHANGED% Number of Changed ltems in Post-Analyze
%ERRORS%  Number of Errors in Post-Analyze or Post-Sync
%CONFLICTS% Number of Conflicts in Post-Analyze or Post-Sync
%SYNCOK%  Number of Synced-OK items in Post-Sync

Program-name can be BAT file, EXE file or any executable file.

If program-name is not absolute, it should be on your executable PATH.

If program name contains spaces, it must be enclosed in double quotes like so:
"C:\Documents and Settings\John Smith\My Documents\myscript.vbs"

Program name may contain %GSDISK% variable replaced with the disk GoodSync was started from,
like so:

"%GSDISK%\folder1\folder2\program bat"

if you want to start this program from the disk on which GoodSync2Go resides.

Example: call Notepad to show log file:
notepad %LOGPATH%

Format 2: If program name is specified with %ALLARGS% arguments then the program receives 7
arguments:

1. Job name.

2. Terminal error message. Empty is no terminal error has happened.

3. Log File Path. Log may not exist or be empty if terminal error occurred. Nonterminal error messages
are contained in this log file.

4. Left Sync Folder Path.

5. Right Sync Folder Path.

6(A). Number of Changes (Post-Analyze only).

6(S). Number of tems synced OK (Post-Sync only).

7. Number of Non-Terminal Errors (Post-Analyze and Post-Sync),

8. Number of Conflicts (Post-Analyze and Post-Sync).

Format 3 (deprecated): If program name is specified without arguments then the program is started
without any arguments.

GoodSync waits for the program to finish before proceeding.
However, if program name is prefixed with "nowait: ", then GS does not wait.

If program name is prefixed with "errors: ", then it is started only if errors occurred in Analyze or Sync.
Advanced tab

Safe Copy using temporary files (checked by default)

If checked, then Sync does not copy source file directly to the destination file, as it would result in
corruption of destination file is copy operation is aborted mid-way. Instead Sync copies source file to
temporary file in destination folder and once copy operation is finished, temporary file is renamed to the
destination file.

You may uncheck this option if you are doing 1-way backups and destination volume has small free
space, so that keeping two copies of one big file may overflow it.

Copy ACL Security Attributes (un-checked by default)
If checked then copy Access Control List (ACL) of the file or folder when it is being copied by



GoodSync. This option is available only on Windows NTFS file system (not on FAT), as only NTFS has
ACL.

Check that files did not change between Analyze and Sync (un-checked by default)

If checked then verify that files did not change between Analyze and Sync both for Remote file systems
and Local Windows file system.

If unchecked then perform this verification only for Local Windows file system.

Turning this option On slows down remote Syncs but guarantees better file integrity.

Copy Locked Files (checked by default)

If On then copy from locked files using Volume Shadow service.

If Off then return Cannot Copy Locked File error.

Available on Vista, Windows 7 and XP but not on Windows 2000.

On 64-bit Windows XP, Vista and 7 you must use GoodSync 64-bit version for this to work.
GoodSync can copy only FROM locked file and never to LOCKED file.

GoodSync can copy only from locked file on local disk, never from a network-mounted locked file.

Case-Sensitive File and Folder Names (checked by default)

If On then FILE.txt and file txt will be treated as different file names.

Renames that change only file name case can be propagated even in Windows with this option On.
If not checked then FILE ixt and file txt is treated as the same file name.

When changing this flag, you must Reset State for this job and resync all files.

We really do NOT recommend unchecking this option.

Fast Pre-Analyze using timestamps (un-checked by default, except for RoboForm jobs)

If checked then before doing Analyze check whether timestamp file on server side of the jobs has
changed. If it did not change then skip Analyze for the server side of the job and assume there was no
changes there.

If not checked then always perform full Analyze.

Conditions for use of this option: (1) one of the job sides should be on server, the other local, (2) server
promises to never change any files in sync folder other than via GoodSync ver 8.14 or later, (3) if
server changes any files by itself, it promises to delete timestamp file _gsdata_\stamp.gsl.

Folder Symbolic Links Processing (Copy As Is by default)

This option determines how symbolic links to folders are processed.

* Ignore. Symlinks to folders are ignored and not copied in any way.

* Copy As Is. Symlink to folder is copied as the same Symlink in the destination folder.
* Drill Down. Target folder of symbolic link is be copied to the destination folder.

File Symbolic Links Processing (Drill Down by default)
This option determines how symbolic links to files are processed.
* Ignore. Symlinks to files are ignored and not copied in any way.

* Copy As Is. Symilink to file is copied as the same Symlink in the destination folder.
* Drill Down. Target file of symbolic link is copied to the destination folder.

Global Program Options
General tab

These global options apply to all jobs, to the entire GoodSync program.



They are called by Tools -> Program Options command or ALT+P.

Language (default: English)

Select user interface language for GoodSync.

You must restart GoodSync for the language change to become effective.
Supported languages are listed on the Translations Page.

Show GoodSync icon in system tray (on by default)
If checked then: When GoodSync runs, it shows its icon in System Tray.
If not checked, then: GoodSync does not show anything in System tray when it runs.

Hide to System Tray when Main Window is closed (off by default)

If checked then: When you Close GoodSync, it will run in the background and it will show System Tray
icon.

To access GoodSync, double-click GoodSync icon in System Tray (desktop lower right corner).

If not checked, then: When you close GoodSync, it unloads from memory.

Start GoodSync when Windows starts (off by default)

If checked then Windows starts GoodSync automatically when you log in to your Windows account.
Started this way, GoodSync shows only taskbar icon and no main window.

You can double<click the icon to call up the main GoodSync window.

Turn this option on if you run jobs automatically, that is, if you checked any boxed in Job Options -> Auto
tab.

Reset all information messages to default
If checked then GoodSync resets no-show status of all warning messages that can be turned off.

Check for a new version daily (on by default)
If checked then GoodSync will contact www.goodsync.com daily to check whether the new version is
available.

Create left/right Sync folders if they are not found (off by default)
If checked then GoodSync will create left/right sync folders if they are not present.
If not checked, then error message will be shown on Analyze if sync folders are not present.

Auto-hide Mini Window when there is no active jobs
If checked and Mini Mode windows is shown then GoodSync will hide this window when all active jobs
finish running, after a delay of about 30 sec.

Save Logs, Level of Detail

GoodSync writes log file named YYYY-MMDD-ComputerName-JobName.log to _gsdata_ folder in the
Left and the Right sync folders of the job.

Here YYYY is current year, MM is current month, DD is current day, ComputerName is the name of this
computer, JobName is the name of the job that ran.

A new job log file is created for any Analyze + Sync combo, or for Analyze with no Sync. For servers,
job logs are initially written locally and they are uploaded to remote server _gsdata_ folder at the end of
the Sync.

Critical

Important non-error messages that must be seen.
Error

Errors that terminates a job, shown in red.
Information (default value)


http://www.goodsync.com/mac/translate

Warnings or major action performed, includes sync actions.
Details
Details on actions performed, no need for most users to see.

Save Logs In Folder

GoodSync also writes global log of all actions it performs to file named GoodSync_YYYY-MM-DD.log
that is located in folder C:\Users\<User Name>\AppData\Roaming\GoodSync (on Win XP:
C:\Documents And Settings\<User Name>\Application Data\GoodSync).

Log files written by Unattended mode start with 'gsync' prefix,, instead of 'GoodSync'.

If 'Save Logs In Folder' option is specified (not empty) then GoodSync writes global logs to the folder
specified in this option.

Retain logs for this many days (7 by default)

Number of days for which global and job logs are retained.

Log files that are older than the specified number of days are deleted when GoodSync starts.
0 days means: retain logs for 2 hours.

Compare Files Using External Program (on by default)

If checked then call external file compare program when you select
Compare Left to Right from file context menu that is available after Analyze.
If one of the files is located on remote file system, it is downloaded first.

File Compare Program (empty by default)

Specifies path to the external file compare program used above.

This external program receives two arguments: path to left and right file.

If the program is not specified (blank field) then the default file compare program is used.

UNIX diff is the default file compare program.

It shows line difference for text files only.

If invoked on folders, it compares all files in the selected folder and its subfolders.
Byte comparison of all files can take a long time on slow file systems.

Filters tab

In addition to job-specific Included and Exclude filter you can specify global (program-wide) filters in this
tab.

The effective Exclude and Include filters used for the job are
the sum of job-specific Exclude and Include filters and program-wide filters from this tab.

Connection tab

Use this tab to specify connection proxy that is used by:

(i) all jobs that have Use Proxy option checked,

(i) AutoUpdate and version checker,

(iii) Activation of Pro version, when talking to GoodSync server.

Use Proxy Server used by Internet Explorer (checked by default)

If checked then use the same proxy server as the one that Internet Explorer and WIinINET use.
GoodSync may be unable to handle some complex proxies, such as ISA proxy with NTLM auth.
Another proxy handling alternative for WebDAV file system is to check WInINET checkbox under



Browse button, this would cause GoodSync to use WInINET socket layer instead of our own socket
layer.

Use this Proxy Server (unchecked by default)
If checked then use the proxy server specified below.

Host name and Port (empty by default)

Host name and port of the proxy server.

SFTP uses a different socket layer, so if you want to specify proxy for SFTP connection, you must use
PuTTY session for this. See details in SFTP section.

Proxy UserID and Password (empty by default)
If not empty, use these credentials as UserID and Password
for Proxy specified above or derived from IE settings.

Use SMTP server to send emails (unchecked by default)

If checked then use SMTP server specified below to send Post-Sync and Post-Analyze emails to the
addresses that are specified in Job -> Options -> Scripts.

If unchecked then use default MAPI client of your computer to send these emails.

SMTP Server (empty by default)
IP name or address of SMTP server that is used to send emails.

SMTP Port (empty by default)
Port on SMTP server that is used to send emails.
Default values: 587 or 25 for non-secure connection, 465 for secure SSL connection.

SMTP UserlD and Password (empty by default)
If your SMTP server requires authentication (most servers do these days), specify your credentials
here.

Sender's Email (empty by default)
E-mail address of the sender that will be used in emails that GoodSync sends.

Secure SMTP submit over SSL (unchecked by default)
If checked then talk to SMTP server using SSL, so that connection is encrypted.
If not checked, use plain text communication.

Example: using GMail SMTP server:
SMTP server = smtp.googlemail.com
SMTP port = 465

User Name = yourname@gmail.com
Password = yourpassword

Secure SMTP over SSL = checked

About tab

This tab show version and use information.

It also contains Check for Updates button that checks www.GoodSync.com for its most recent version.

Back to the Top

TIX: Readable Job Descriptors
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Starting with version 8.1.9, GoodSync can export, import, write and read
list of its jobs in new human readable XML-ike text format called TIX.
Originally, only the TIC format was available.

TIC is a short text format but which is not human readable or editable.

Using TIX instead of standard TIC provides several benefits:

- Automation: Edit and generate GoodSync jobs without starting GoodSync GUI.

- Automation: Load job list in TIX format from registry not file, for easy mass job distribution using Active
Directory.

- Archiving: Readable and printable backup format for job list.

A typical job description in TIX looks like this:

Name = "job Name"
Dirl =
Url = "C:\\My RF data"
Dir2 =
Url = "https://online.roboform.com/users/user4id"
UserID = "user4id"
PasswordGarbled = "secret_password"

BadCerts = No

Direction = 0
lwayMode = 0
FiltersExcluded =
Matches = (
"RoboFormDataHere. txt"
"options.rfo"
"cvs"
" cvsignore"
)
ExcludeHidden = Yes
ExcludeSystem = No
ReconnectAttempts = 1

TIC and TIX, File and Registry: Who decides.

These four registry values control format and source of loading and saving of the job list and program
options. These values are taken from registry key "HKEY_CURRENT_USER\Software\Siber
Systems\GoodSync" and they are DWORDs.

JobsLoadRegistry = 1 :load job list and program options from registry values in TIX format.
JobsLoadRegistry = 0 :load job list form jobs tic file, program options from options tic file. Default.
JobsSaveRegistry = 1 : save job list and program options to registry values in TIX format.
JobsSaveRegistry = 0 : save job list to jobs tic file, program options from optionstic file. Default.

If option to load job list from registry or save to registry is set then registry values
"HKEY_CURRENT_USER\Software\Siber Systems\GoodSync\Jobs\job-nameltix" are used. Each job
gets its own registry key and value named "tix" in that key contains TIX string that describes the job. TIX
string does not have newline characters.

If option to load program options from registry or save to registry is set then registry value
"HKEY_ CURRENT _USER\Software\Siber Systems\GoodSync\ProgOptionsTix" is used. It contains
program options encoded in TIX.



General Rules.

There can be more than one job in jobs tix file.

Newline characters can be used to improve readability, but they are not required.

Each property is recorded as "name = value", where value can be a single constant, an object in object
brackets, or a list presented as "( element1 element2 ... elementN)".

Boolean constants can appear "Yes", "No", "T" or "F".
Strings appear as "text" (double quotes required).

You can represent special characters in the string this way:
\n new line

\\ backslash

\" double quote character

\NNN; non-printable character whose decimal code is NNN.

Job Properties.
Appears in <Job> ... </Job> brackets.

Name = "Job Name"

Dir1 = <Connect> ConnectoidProperty ... </Connect>

Dir2 = <Connect> ConnectoidProperty ... </Connect>
Direction = 0 for 2-way | 1 for Left to Right | 2 for Right to Left
1waymode = 0 for Forced | 1 for Verified | 2 for Delete Source
ReadOnlySource = Yes | No

PropagateDeletions = Yes | No

SavePreviousVersion = Yes | No

SavePastVersions = Yes | No

EstimateRequiredSpace = Yes | No

AutoReconnect = Yes | No

ReconnectAttempts = number

SpeedLimit = number

ShowBalloon = 0 for Never | 1 for On Errors | 2 for On Errors and Info

ExcludeEmptyFolders = Yes | No

ExcludeHidden = Yes | No

ExcludeSystem = Yes | No

Filtersincluded = Matches <FileMask> ( "string" ... ) </FileMask>
FiltersExcluded = Matches <FileMask> ( "string" ... ) </FileMask>

OnFolderConnectAction = 0 for No | 1 for Analyze | 2 for Analyze and Sync
OnStartAction = 0 for No | 1 for Analyze | 2 for Analyze and Sync
OnTimerAction = 0 for No | 1 for Analyze | 2 for Analyze and Sync
TimerlntervalHours = number of hours

TimerlntervalMinutes = number from 0 to 59

OnLogoutAction = 0 for No | 2 for Analyze and Sync

OnRoboFormAction = 0 for No | 1 for Analyze | 2 for Analyze and Sync
LimitChangesPercent = number from 0 to 100

AutoResolveConflicts = O for disable | 1 for LtoR | 2 for RtoL | 3 for Newer Wins
AutoClearTree = Yes | No

PreAnalyzeScriptOrEmail = "string"
PostAnalyzeScriptOrEmail = "string"
PostSyncScriptOrEmail = "string"



CopyUsingTempFile = Yes | No
CopyLockedFiles = Yes | No

CopyACL = Yes | No

CaseSensitive = Yes | No
FastPreAnalyzeWithStamps = Yes | No

Connectoid Properties.
Appears in <Connect> ... </Connect> brackets.
GoodSync connectoid describes how to connect to the server.

Url = "string"
UserID = "string"
PasswordGarbled = "string"

Utf8 = Yes | No (all server file systems)
UseProxy = Yes | No (all server file systems)

BadCerts = Yes | No (DAV only)
Winlnet = Yes | No (DAV only)
AccessPolicy = "string" (S3 only)
HostBasedAddr = Yes | No (S3 only)

ActiveMode = Yes | No (FTP only)
UseMDTM = Yes | No (FTP only)
PingControl = Yes | No (FTP only)
ImplicitMode = Yes | No (FTP only)
PrivateKey = "filepath" (SFTP only)
ServerProfile = "file-path" (SFTP only)

Decrypt = Yes | No (Windows EFS only)
Encrypt = Yes | No (Windows EFS only)
Compress = Yes | No (Windows Local only)
Uncompress = Yes | No (Windows Local only)

Program Options.
Appears in <ProgramOptions> ... </ProgramOptions> brackets.

GlobalFilterincluded = Matches ( "match-string" ...)
GlobalFilterExcluded = Matches ( "match-string" ...)
HideToTrayOnClose = Yes | No
WarnAboutTrayOnClose = Yes | No

ShowTraylcon = Yes | No

ShowdJobListWindow = Yes | No
ShowFiltersWindow = Yes | No

ShowLogWindow = Yes | No

ShowStatusBar = Yes | No

GroupSimilarLogLines = Yes | No
CheckNewVersion = Yes | No
CreateFolderlfNotFound = Yes | No
AutoHideMiniWindow = Yes | No

LoglLevel = 0 for critical | 1 for errors | 2 for info | 3 for details
LogRetainDays = NNN (number of days)
LogFolder = "folder-path"

CompareProgramPath = "file-path”



UseSmtpToEmail = Yes | No

Smtpimported = Yes (imported already) | No (import from windows)
SmtpServer = <SmtpServer> SmtpServer-property ... </SmtpServer>
ProxyServer = <ProxyServer> ProxyServerproperty ... </ProxyServer>

SMTP server.
Appears in <SmtpServer> SmtpServer-property ... </SmtpServer> brackets.

Host = "IP name of SMTP server"

Port = NNN (recommended: 587 for No SSL, 465 for SSL)
UserlD = "user-d for authenticated SMTP"

Password = "password for authenticated SMTP"
SecureSSL = Yes | No

SenderEmail = "sender@company.com"

Proxy server.
Appears in <ProxyServer> ProxyServer-property ... </ProxyServer> brackets.

UseWinlnetProxy = Yes (use proxy of Internet Explorer / Winlnet) | No (no auto proxy)
UseProxyBelow = Yes (use proxy specified below) | No (no proxy)

Host = "IP name of proxy server"

Port = NNN (port on proxy server)

UserlD = "user-d for authenticated proxy"

Password = "user-d for authenticated proxy"

Command Line

GoodSync can be started from command line and everything that you can do from GUI can be done
using command line options described here.

Command line call has this general format:
goodsync [<global-option>] <command> <command-options>

GoodSync Pro/Free can only start execution of existing jobs via command line,
all other command line options (create, delete, modify job) are available in GoodSync Enterprise only.

Global Options

*** Run Mode Options ***

/help
Show help message that lists command line options and exit.

Iprofile=<profile-folder>

GoodSync profile folder, job list is loaded from file jobs.tic in this folder unless option /jobs is specified.
Global program options are loaded from file options.tic in this folder.

Global Log files are wriiten to this profile folder.

ljobs=<job-list-file>
If specified, then load job list from this file. File format is TIC or TIX, depending on file extension.

loptions=<options-file>
If specified, then load global options from this file. File format is TIC or TIX, depending on file extension.



/min
Run minimized, only taskbar icon is visible.

[forcetray
Run minimized to tray, do not allow main window to show.

/miniwin
Start in mini window mode, allow main window to be shown.

[forceminiwin
Start in mini window mode, do not allow main window to show.

lexit
GoodSync will exit upon completing the action requested in command line.

lexit-ifok

GoodSync will exit upon completing the action requested in command line,
if return code is zero, that is, if no errors occurred.

If errors did occur in the last job that ran, then GoodSync will not exit.

*** Global Program Options ***

Isystem-tray=yes|no
Show system tray icon. Default: yes.

ltray-on-close=yes|no
Closing GoodSync causes its minimization to system tray. Default: no.

Icheck-new-ver=yes|no
Check for New Version. Default: yes.

Icreate-folder-if-notfound=yes|no
Create job sync folders if not found. Default: no.

lauto-hide-mini-win=yes|no
Auto-hide mini-window when there is no job activity. Default: yes.

Ni=0]1|2|3|9

Set log level to N (number from 1 to 3).

0 — critical messages (job start and stop),
1 —error messages

2 —informational messages (default level)
3 —detailed messages

9 - no log at all (valid only for gsync)

lif=<log-folder>
Write global log to <log-folder>. If not specified, write global log to profile folder.
Path should be an absolute path on local computer.

llog-retain-days=NNN
Number of days for which old logs are retained. Default: 7.

Igroup-log-lines=yes|no
Group similar log lines. Default: yes.



Icompare-prog=<ExeFilePath>
Use this program to compare two files diff style when user selects Compare from item context menu.
If nothing is specified then UNIX diff is used.

/proxy-auto=yes|no
Use Wininet proxy (the one used by Internet Explorer).

Iproxy-host=<host-name>
Use proxy server set here by IP address or name, negates /proxy-auto option.

Iproxy-port=<port-number>
Use this port on the proxy server specified in /proxy-host.

Iproxy-userid=<userid>
UserlID for proxy, both manual and auto.

Iproxy-passwd=<password>
Password for proxy, both manual and auto.

Ismtp-host=<host-name>
Use SMTP server set here by IP address or name.

Ismtp-port=<port-number>
Use this port on the SMTP server specified in /smtp-host.

Ismtp-secure=yes|no
Use SSL (encrypted connection) when submitting email to SMTP server.

Ismtp-userid=<userid>
UserlD for SMTP server.

Ismtp-passwd=<password>
Password for SMTP server.

Ismtp-sender=<name-email>
Sender of Emails: "email@company.com" or "FirstName LastName ".

llist-changes=yes|no
Print List of changes detected by Analyze to the log.

Isave-global-options
Save global GoodSync options as changed by command line.

Commands

analyze /all
Analyze all jobs.

analyze <job-list>
Analyze listed jobs, job names are separated by space.
Job names containing spaces must be enclosed in quotes like this: "Job Name"

sync /all
Synchronize all jobs.



sync <job-list>
Sync listed jobs, job names are separated by space.
Job names containing spaces must be enclosed in quotes like this: "Job Name"

job-tmp <job-name> [<job-options>]

Create a temporary job with specified job options and Analyze/Sync it.

This job is never added to the list of jobs and it exists only in memory during execution.

This command is available only in GSYNC (pure command line) and not in GOODSYNC (GUI version).

job <job-name> [<job-options>]
Create a new job or update an existing job with specified job options.

job-new <job-name> [<job-options>]
Create a job with specified job options.

job-update <job-name> [<job-options>]
Change specified options in the existing job.

job-delete <job-name>
Delete existing job.

Job Options

lanalyze
Analyze Job after it has been created or updated.

Isync
Analyze and Sync Job after it has been created or updated.

*** Connectoid Options ***

[f1=<full-folder-path>

Left sync folder.

Full Folder Path should be in one of these formats:
C:folder1\folder2\file .ext
\\share\disk\folder1\folder2\file .ext
ftp//serverdomain.com:port/folder/file
sftp//serverdomain.com:port/folderffile
http//server.domain.com:port/folder/file

Use quotes around paths with spaces.

If2=<full-folder-path>
Right sync folder.
For Full Folder Path format see the above item.

luserid1=<user-id>
UserlID for left sync folder.

luserid2=<user-id>
UserlD for right sync folder.

Ipassword1=<password>



Password for left sync folder.

Ipassword2=<password>
Password for right sync folder.

lencrypt1(2)=yes|no
Encrypt files in the left (right) sync folder using EFS.

/decrypt1(2)=yes|no
Decrypt files in the left (right) sync folder using EFS.

utf8-1(2)=yes|no
UTF-8 encoding (No: ANSI) for left (right) folder.

/bad-certs1(2)=yes|no
Do not check SSL server certificates for left (right) folder.

Iwininet(2)=yes|no
Use Winlnet implementation of the file system in the left (right) for DAV, S3, FTP.

luseproxy1(2)=yes|no
Use proxy to connect to the left (right) folder.

/hostbased1(2)=yes|no
Use host-based addressing (S3).

laccesspolicy1(2)==<access-policy>
Pre-cooked access policy for left (right) folder (S3).

Isend-cookies1(2)=yes|no
Send cookies for left (right) DAV folder.

lactive1(2)=yes|no
Active FTP mode (No: passive) for left (right) folder.

/Imdtm1(2)=yes|no
Use MDTM command for left (right) FTP folder.

limplicit1(2)=yes|no
Implicit FTPS mode (No: Explicit mode) for the left (right) folder.

Ipingcontrol1(2)=yes|no
Ping control connection when sending large file via data connection (FTP).

Ipk1(2)=<folder-path>
SFTP private key file absolute path, for left (right) sync folder.

Ipsession1(2)=<session-name>
PuTTY session name for the left (right) folder, SFTP connection.

*** General Options ***
/dir=2way | ltor,forced | ltor,verified | rtol,forced | rtol,verified

Job direction: 2-way, Left to Right (ltor), or Right to Left (rtol).
One Way Mode that appears after ltor or rtol can be: forced or verified.



Ireadonly-src=yes|no
Read-Only Source Side option. Can be turned on only in 1-way Forced job.

/deletions=yes|no
Propagate Deletions option.

Isave-disposed-files=yes|no
Saved files overwritten or deleted by GoodSync to _gsdata \ saved_folder.
Only one last version of the file is saved.

Isave-past-versions=yes|no
Saved past versions of file overwritten or deleted by GoodSync to _gsdata_\ history folder.
Many file versions are saved, one per every overwrite or delete of the file.

lest-req-space=yes|no
Estimate Required Free Space option.

Ireconnect=yes|no
Automatically Reconnect when folders disconnect.

Ireconnect-attempts=<number>
Number of Reconnect Attempts.

Ispeed-limit=<number>
File Copy Speed Limit in Kb/sec.

/balloon-msg=nonelerrors|changes
Show Balloon option.

*** Filter Options ***

lexclude=<file-mask>
Exclude filter.
File Mask is a comma-separated list of patterns such as *.obj or \folder\file.

linclude=<file-mask>
Include filter.
File Mask is a comma-separated list of patterns such as *.obj or \folder\file.

lexclude-empty=yes|no
Exclude Empty Folder option.

lexclude-hidden=yes|no
Exclude Hidden Files and Folders option.

lexclude-system=yes|no
Exclude System Files and Folders option.

*** Auto Options ***

lon-start=analyze|sync|no
Automatically Analyze/Sync on Start of GoodSync.

/autostart-delay=NN



On Start delay in seconds.

lon-folder-connect=analyze|sync|no
Automatically Analyze/Sync on Folder Connect.

lon-file-change=analyze|sync|no
Automatically Analyze/Sync on any File Change inside local sync folders.

lon-logout=sync|no
Automatically Sync on Logoff from Windows account.

lon-timer=analyze|sync|no
Automatically Analyze/Sync on Timer (every N minutes).

[timer-period=<NN>
Timer period in minutes for /on-timer option.

lon-roboform=analyze|sync|no
Automatically Analyze/Sync on RoboForm command.

llimit-changes=<NN>
No Sync If Too Many Files Changed option.
NN is a number from 0 to 100.

lautoresolve=nol|left|right|newer
Auto-Resolve Conflicts option: No Copy, Left wins, Right wins, Newer wins.

/autoclear=yes|no
Auto Clear tree after Sync.

*** Script Options ***

Ipre-analyze-action=<email-addr|program-path>
Pre Analyze Program.

Ipost-analyze-action=<email-addr|program-path>
Post Analyze Email or Program.

Ipost-sync-action=<email-addr|program-path>
Post Sync Email or Program.

*** Advanced Options ***

Itemp-dest-file=yes|no

Use temporary files when copying from source to destination, so that sudden interruption of copy does
not result in corrupted file.

Icopy-acl=yes|no
Copy ACL security attributes.

Icheck-file-stability=yes|no
Check Analyze-Sync File Stability on Remote File Systems option.

Icopy-locked=yes|no
Copy Locked Files using Shadow Copy Service on Windows XP, Windows Server 2003, Vista,



Windows 7.

Icase-sensitive=yes|no
Case Sensitive file and folder names.

[fast-pre-analyze=yes|no
Fast Pre Analyze Mode.

[folder-links=ignore|copy-asis|drill-down
Folder symbolic links processing mode.

[file-links=ignore|copy-asis|drill-down
Folder symbolic links processing mode.

Installer Options and Activation of Enterprise Version

The options below are installer options, that is, they are specified for the installer GoodSync-Setup.exe,
not for GoodSync.exe.

lorderid=1234567890

lusername="John Smith"

If /orderid and /username options are specified then GoodSync Pro is automatically activated upon
install using the specified OrderID and User Name. Note that this is online activation, so GoodSync.exe
should be able to get to www.goodsync.com.

Iproxy="Proxy User Name, Proxy Password"
If online connection on your computer requires password-protected proxy and you are using /orderid
and /username options then specify Proxy User Name and Proxy Password using this option.

IS
Run installer silently, no input from user is requested.

Enterprise Activation
For those deploying GoodSync in an Enterprise environment, you can install and activate using the
above mentioned parameters of OrderID and Company Name from the purchase. An example being:

GoodSync-Setup.exe /S /orderid=0123456789 /username="Company Name"

This will run the GoodSync installer silently, and attempt to activate the software using the OrderID and
Company Name specified.

Post-Install Activation
Activation of GoodSync Pro or Enterprise can be performed after the product has already been
installed.

The following command will activate GoodSync Pro license:

GoodSync.exe /install /orderid="xxxxxxxxxx" /username="XxXXXX XXXXXXXXXX"

This command will activate GoodSync2Go Pro license:

GoodSync.exe /install /port /orderid="xxXxXXXXXXxXX" /username="XxXxXXXX XXXXXXXXXX"



Return Codes

If global option /exit is specified then GoodSync.exe returns
integer return code that describes result of the last job execution:
0 — Analyze or Sync success

1 - Analyze User Stop

2 — Analyze with Terminal Error

3 — Analyze with Non-Terminal Errors

4 — Analyze with Conflicts but no Errors

5 — Analyze with Conflicts and Errors

11 — Sync User Stop

12 — Sync with Terminal Error

13 — Sync with non-Terminal Errors
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Policies

Policies are used by system administrator to enforce enterprise-wide rules that limit or change
GoodSync behavior.

Policies are available in GoodSync Enterprise only.

To edit policies, use the GoodSync policy template:

- Select Start -=> Run, type: gpeditmsc, press Enter.

- In the tree go to 'Local Computer Policy' = 'Computer Configuration' -=> 'Administrative Templates'.
- Right-click 'Administrative Templates', select 'Add/Remove templates' > 'Add...,

- Browse for goodsync.adm in 'Program Files\Siber Systems', click 'Close'.

- The new sub-tree with GoodSync policies will appear under 'Administrative Templates'.

- To enable a policy, select this policy in Editor, right-click it, select Enabled.

- Policy will become effective after GoodSync restart.

These policies are available:

- ForceMiniMode: Start GoodSync in MiniMode and do not allow expanding it to the full size
- ForceTray: Start GoodSync minimized to tray and do not allow expanding it to the full size
- NoAutoUpdate: Disable AutoUpdate

- NoJobListEdit: Do not allow to add/delete/rename jobs

- NoJobEdit: Do not allow to change job paths or options

- NoProgramOptions: Do not allow to change program options

- NoJobOptions: Do not allow to change job options

- NoOptionsGeneral: Do not allow to change General job options
- NoOptionsFilters: Do not allow to change job filters

- NoOptionsAuto: Do not allow to change job auto options

- DisableFTP: Disable FTP file system support

- DisableSFTP: Disable SFTP file system support

- DisableDAV: Disable WebDAV file system support

- DisableS3: Disable Amazon S3 file system support

- DisableWinCE: Disable Windows Mobile devices support



Syncing Specific Applications
This section tells you how to setup syncing for popular applications.

RoboForm.

Latest versions of RoboForm have command RoboForm -> Tools -> Sync Data that setup sync job and
start GoodSync automatically. If setting up manually, you should synchronize folder My RoboForm Data
between two computers that you are syncing, or between computer and USB drive with RoboForm2Go.
These computer-specific files will be excluded from sync: license.rfo, cache rfo, mru.rfo. You may include
file options.rfo, it contains RF options.

Outlook.
Synchronize file Outlook.pst that contains Outlook data.

Open Outlook application locks file Outlook.pst, not allowing GoodSync to sync it.

Outlook must be closed for this file to be unlocked.

If you sync your Windows Mobile phone or Pocket PC with desktop, then Outlook pst file is locked while
your phone is plugged in. Pull out your phone from the cradle for Outlookpst to be unlocked.

Outlook.pst file location:

* XP: C:\Documents and Settings\User Name\Local Settings\Application
Data\Microsoft\Outlook.

* Vista and Windows 7: C:\Users\User Name\AppData\Local\Microsoft\Outlook .

How to make Outlook store your Outlook.pst in the folder you like:

* Move Outlook pst from the standard folder to the folder where you want it to be.

* Start Outlook — it tells you that it cannot find Outlook.pst.

* Outlook offers you to specify location of Outlook.pst. Select the folder where Outlook.pst is now.

Outlook Express.

Outlook Express (OE) stores its data in several files, located in OE data folder. To find where this folder
is, open OE and go to Tools -> Options -> Maintenance -> Store Folder . It will show you where the
data files are and you can change this location of the folder too. Sync the entire folder. Sync only when
OE is closed, as OE may lock the files it uses.

Windows Mail (Vista Only).
Sync Windows Mail data folder. It is located at
C:\Users\User Name\AppData\Local\Microsoft\Windows Mail

Quickbooks.

Quickbooks (QB) stores all its data in one file that has format CompanyName.QBW . This is the file to
sync. Quickbooks backup files have extension QBB. We recommend to back up the QBW file using
native QB Backup command and to sync the backup file too, for extra protection. Quickbooks locks the
QBW when opened, so you must close QB before syncing. Even if you opened QBW file to only view it
and not to modify it, QB will still modify this file. So you cannot use GoodSync for 2-way syncing of

* QBW files, you can do only 1-way backup.

ACT!

Act locks its data files and when you close ACT, they are still locked. This is because ACT! installs a
SQL service that is active even when the ACT! application is not running. This service keeps ACT! data
files locked. You should stop the MSSQL ACT! service temporarily to be able to sync these files: Go to
Start/Control Panel/Administrative Tools/Services, locate the service named "MSSQL$ACT7" (or
something similar), stop it, do the synchronization, and then start the service again. Alternatively, you can
permanently exclude ACT! files from synchronization.
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GoodSync2Go: Portable version

GoodSync2Go is a portable version of GoodSync that is:

- Installed on removable drive (USB key or Portable Hard Drive), not on computer.
- Runs from the removable drive on which it is installed.

- Stores list of jobs and other settings on the removable drive.

- Licensed per removable drive, no per-computer license is required.

Otherwise it does the same things as regular version.

Limitations of GoodSync2Go:
- Cannot run GoodSync2Go jobs from Windows Scheduler, because Scheduler is computer-specific.
- Cannot start GoodSync2Go when Windows starts, this is computer specific too.

GSYNC: pure Command Line version

GSYNC is a pure command line version of GoodSync that is only available in GoodSync Enterprise.
It does not present any GUI (Graphical User Interface) at all, so it is ideal for:

e calling from batch files,
¢ calling from other programs,
¢ calling from services such as Scheduler.

GSYNC accepts exactly the same command line arguments as GoodSync.exe except as noted below.

Icheck-ver
If set then check whether this GSYNC versin is current, report to stdout.

Iprofile=<profile-folder>

GoodSync Profile folder.

This is folder from which GoodSync reads job list file, global options file, and to which it writes global
logs.

If not specified, profile folder is C:\Users\User Name\AppData\Roaming\GoodSync or similar locatio
non XP.

Path should be an absolute path on local computer.

lif=<log-folder>

Write global log to <log-folder>.

If not specified, write global log to profile folder.
Path should be an absolute path on local computer.

N=0|1]2|3|9

Setlog level to N (number from 1 to 3).

0 — critical messages (job start and stop),
1 - error messages

2 —informational messages (default level)
3 —detailed messages

9 —no log at all.

llicense



If set then show current license and exit.

Iprogress=yes|no
Show progress messages when downloading or uploading files.
Default: No.

Icleanup-logs=yes|no (default: yes)

If set to 'yes' then cleanup old log files when GSYNC starts.

If set to 'no' then do not cleanup log files when GSYNC starts.

Ol log files is defined as log files that are older than number of days to retain the logs option.

Icleanup-tmp=yes|no (default: no)

If set to 'yes' then cleanup temporary files when GSYNC starts.

If set to 'no' then do not cleanup temp files.

You can use this option ONLY IF there is no other GoodSync or GSYNC processes running on this
computer, as this option deletes all qualifying log and temp files, including that of other running
GoodSyncs.

loverride-locks=yes|no

If set to 'yes' then override lock files on Analyze.

Lock file is created in sync folder by a running Sync job and it is deleted when the job finishes.
Default: No. #if 0

/delegate command-line
If GoodSync.exe runs already then delegate command-ine execution to GoodSync.exe. #endif

ljobs-file=<job-file-path>
If defined then load job list from the specified file in TIC or TIX format, depending on file extension.
If not defined then load job list from file jobs tic in the profile folder.

ljobs-file-save=<job-file-path>
If defined then save job list to the specified file in TIC or TIX format, depending on file extension.
If not defined then save job lists to the same medium (file or registry) from which it was loaded.

loptions-file=<options-file-path>

If defined then load global options from the specified file in TIC or TIX format, depending on file
extension.

If not defined then load global options from file options tic in the profile folder.

loptions-file-save=<options-file-path>
If defined then save global options to the specified file in TIC or TIX format, depending on file extension.
If not defined then save global options to the same medium from which it was loaded.

/jobs-options-registry
If defined then load job list and global options from registry.
If not defined then load job list and global optins from files in TIC or TIX format.

/jobs-options-registry-save

If defined then save job list and global options to registry.

If not defined then save job list and global options to the same medium (file ore registry) from which it
was loaded.

/default-values-tix=yes|no
If set then save options that have default value, when saving in TIX format.



If not set then do not save options that have default value, when saving in TIX format, for shorter TIX
file.

GSYNC runs all jobs specified in the command line sequentially, in the order in which jobs appear in Job
List.

Return Codes for the last job that was run is returned:

0 - Normal completion: Analyze with No Change or Sync with Success.
1 - Analyze with Terminal Errors, error text written to stdout as last line.
2 - Sync with Terminal Errors, error text written to stdout as last line.
Negative - error when initiating GSYNC.

Non-terminal errors do not return error code, these errors are logged to log file.
Log file is written to stdout.
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GSCP: Command Line File System client

GSCP is a command line interface to GoodSync File Systems, similar to a classic command line FTP
client.

Unlike an FTP client, GSCP can be used to script file operations in all File Systems that GoodSync
supports: Windows, Win Mobile, FTP, SFTP, WebDAV, Amazon S3.

Its ideal application is programmatically running file/folder modification sequences using abstraction of
GoodSync File Systems.

This is how to call GSCP:

gscp URL [userid] [password] [sftp-private-key]

where URL designates file system and server to connect to.

UserlD and Password may be embedded in the URL or specified separately after the URL.
4th optional argument is path to SSH private key used in SFTP, then 3rd argument is this key
passphrase.

GSCP call examples:

gscp \\netshare\volume\folder share-userid share-password

gscp wmJ//myphone/folder

gscp ftp//userpassword@servercompany.com

gscp ftp//servercompany.com user password

gscp https//dav-server.storage-co.com userid mypass

gscp sftp//sftp.server.com userid passphrase c\keys\ssh-private-key.ppk

The following commands are accepted by GSCP once it connects to the server:

Command Argument(s) What it does

quit Exit program

Is List the current remote directory

isf file-name Test whether the specified remote file exists
isd dir-name Test whether the specified remote dir exists
pwd Print current remote directory

cd dir-name Change remote directory (no name means connect root)



pld Print current local directory

Icd dir-name Change local directory

md dir-name Create remote directory

rm file-name Delete remote file

rmd dir-name Delete remote folder

rmrf dir-name Recursively delete remote files and folders
mv file-name-1 file-name-2 Rename or move remote file/folder
put file-name Upload local file to remote folder

get file-name Download remote file to local folder
help Show this list of available commands
info Remote file system info

open url Connect to another file system

close Disconnect from current file system
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Mounting Folder via Network: Tutorials

GoodSync synchronizes folders that are mounted on the computer on which GoodSync runs.
Mounting folder on a computer uses Windows machinery and other programs.

We provide tutorials that explain how to do it, even though the exact recipe of how to mount a drive via
Network lies outside of scope of GoodSync manual.

Synchronization between Two Computers on the Local Area Network (LAN)

First you need to decide which computer is Client and which is Server.

Server computer must have Sharing turned on and folder to sync must be Shared on the Server.
Client computer must have GoodSync installed. Client computer mounts folder to share from Server.
Both computers must be sitting on the same Local Network (LAN).

Usually a bigger computer that is constantly connected to the network gets to be the Server and smaller
computer that is not always connected gets to be the client.

If you are trying to synchronize a Desktop and a Laptop, we recommend you designate you Desktop to
be the Server and your Laptop to be the Client.

1. Share Folder on Server Computer (done once per folder).

Open folder to share in My Computer or in Windows Explorer.

Right-click the folder and select Sharing and Security.

Click "Share this folder on the network".

Assign Share Name to your folder, this name will be what you see on the Client.

Check box "Allow network users to change my files". GoodSync should be able to read and write
files in the folder you share.

¢ Click OK and wait for Windows to set permissions on the folder.



1a. Share entire Disk on Server Computer (alternative to sharing individual folders).

You may want to share not just one folder, but the entire disk, in this case you do not have to go through
folder sharing procedure for every folder you need to sync. Instead, please follow the steps described
below.

¢ Go to My Computer or Windows Explorer and right-click Disk drive,
e Select Sharing and Security,
e Check Share This Folder.

2. Set or Get your Server Name (done once per server computer).

e On the Server computer, right-click My Computer and select Properties, then click Computer
Name tab.

¢ Full Computer Name shows the Name of your Server computer.

¢ [f this name is meaningless, change it to something you can recognize by clicking Change button.
Usually computers are named after person who uses them or their location. Examples: Scott
Laptop, Susie Dell.

3. Mount Shared Folder on the Client.

Go to the Client computer where GoodSync is installed.

Select Job > New to create a New Job and name this job.

Click left Browse button and select folder on the Client computer to sync with.

Click right Browse button. This is where we will enter the shared folder that we mount from Server
to the Client.

Select My Network tab, it shows a list of computers visible on your network.

Select the Server computer, open it and select the folder that you Shared on server.

Click OK and you Job is ready to Analyze and Sync.

If your computer is not immediately visible in My Network, you can type direct address of the
Shared folder as \\ServerName\ShareName where ServerName is the name of your Server and
ShareName is the name that you assigned to the shared folder.

Non-Secure Synchronization between Two Computers on the Internet

To synchronize two computers (Client and Server) over the Internet, a network disk can me mounted via
Internet.

Please follow the instructions below to mount a network disc over Internet.

¢ Windows file sharing does not encrypt file contents in transit, nor does it encrypt disk sharing
passwords that you use. So this method is not secure, as 3rd parties listening on your network
can sniff out passwords and file contents.

e Share a disk on a Server computer: in Windows Explorer right-click drive, select Properties, go to
Sharing tab, check Share This Folder on the Network.

¢ Make Server computer accept connections on port 139. If you have a software or hardware
firewall, config this firewall to allow incoming connections on port 139.

¢ On a Client computer type this into Address bar of Windows Explorer: "\\111.222.333 444\Share".
Here 111.222.333.444 is IP address of the Server Computer and Share is share name of the
shared disk on the Server Computer. You should see the Server folder that you shared.

e Start GoodSync on Client Computer and type the same \\111.222.333 444\Share into the sync
folder path.

e GoodSync is ready to sync.



Secure Synchronization between Two Computers on the Internet

In order to protect files en route while synchronizing between two computers (Client and Server), the
communications channel needs to be encrypted. This is achieved by tunnelling disk mount through SSH
(Secure SHell).

Please follow the instructions below to mount a network drive via SSH.

¢ Install a suitable SSH server on Server Computer or on a computer that sits on a local network
with Server Computer. Using cheap Linux box with SSH as a gateway is an option.

¢ |Install a suitable SSH client on Client Computer.

e Configure SSH client to tunnel connections from port 139 on Client Computer to port 139 on
Server Computer, that is, to IP address of the Server as seen from the computer where SSH
server runs.

e Establish an SSH connection from Client to Server.

¢ On a Client computer type this into Address bar of Windows Explorer: "\127.0.0.1\Share". Here
127.0.0.1 is the address of localhost (that is, Client Computer). Windows Explorer connects to port
139 on Client Computer, SSH client tunnels this connection to the Server computer via SSH
server.

¢ You cannot share other disks on Client Computer, as there is only one port 139 on the computer
and it will be taken by disks you share locally. Non-trivial workarounds exist for this limitation.



