
GoodSync Manual 
To be used with GoodSync ver 7.1.9 and higher.  

This manual is available in PDF for printing.  

Introduction 

GoodSync synchronizes two or more folders with files, that is, GoodSync makes sure that folders and all 
files in them are the same by copying the new or updated files from the folder where they appeared to the 
folder where they are old or not present and by propagating deletions.  

GoodSync can be used in these everyday scenarios:  
* Synchronize notebook computer to desktop computer via local network.  
* Keep user files in sync on work and home computer via USB key.  
* Incrementally Backup all files from main hard drive to portable hard drive or another computer.  

In this Section we discuss challenges that synchronization programs face and that GoodSync successfully 
addresses.  

Backup vs Synchronization.  
Synchronization ensures that two folders remain in sync while user may change files on both sides. This is 
achieved by copying changes that have been made on the left side to the right side and changes that have 
been made on the right side are copied to the left side.  
Backup is one-way synchronization, that is, it changes have been made on the left side are propagated to 
the right side but changes that have been made on the right side are not propagated to the left side. 
GoodSync One-Way Forced jobs enforce the backup scenario. One-Way Verified jobs actually make sure 
that no changes were made on the right (backup) side, as one does not expect backup side to change.  

Why Synchronization Is Not Trivial.  
Synchronization task would appear to be trivial (compare file modification files and let the newer file win) if it 
were not for deletions that need to be propagated. If you delete file on one side, GoodSync will propagate 
this deletion to the other side of sync job by deleting this file on the other side. The sophistication of 
GoodSync algorithm allows us to propagate deletions correctly through multiple chained folders.  
Another complication is that user may decide to replace newer version of the file with its older version. 
GoodSync can handle this situation correctly too, it will propagate the older file version, if it detects that user 
made such replacement.  

Chained Syncing.  
Chained syncing is when you sync several folders (say, A, B, C and D) by performing sync pairs in sequence 
that results in propagation of changes (say, sync A and B, then B and C, then C and D results in changes in 
A propagating to folder B, then C, then D). GoodSync can perform Chained Syncing correctly.  

You can use GoodSync chains to sync files between Computers that are not connected to each other.  
For instance, you can sync files between Work and Home computer using USB disk as intermediary:  
- Insert USB Disk (or any portable disk) into Work Computer.  
- Start GoodSync on Work Computer and Sync between Work folder and USB disk.  
- Pull out USB disk from Work Computer and insert it into Home Computer.  
- Start GoodSync on Home Computer and Sync between USB disk and Home folder.  

Using GoodSync 
Synchronization Step By Step.  
Typical GoodSync user experience consists of these stages:  
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0. Select Folders To Synchronize.  
User selects left and right folders to synchronize.  
Done only once when Job is setup.  

1. Analysis.  
Happens when you click Analyze buttons.  
GoodSync computes the changes that must be made to make folders the same.  

2. Proposed Sync Operations Reviewed by User.  
Results of Analysis are presented to you in a form of file/folder tree.  
Left or Right Arrows point direction of file copy. Circle in the middle means No Copy.  
Crossed Arrow means Propagate Deletion. For instance, Left to Right Crossed Arrow means that GoodSync 
detected deletion of file on the left side and it wants to propagate it to the right side.  
Current effective direction is indicated by arrow or circle being green and thick.  
Other possible directions are indicated by gray and disabled arrows or circle.  
You can change direction of sync by clicking on the desired arrow.  

3. Synchronization.  
Happens when you click Sync button.  
File operations computed in Analysis and possibly changed by user are applied to actual files.  
After synchronization folders and all files in them become the same.  

Jobs.  
Each synchronized pair of folders is memorized in a Job.  
Job also has a set of options that control various aspects of synchronization process.  
Each Job has a name that is requested when Job is created.  
When you start GoodSync for the first time, initial nameless job is created for you automatically.  
GoodSync memorizes list of Jobs and all their parameters per computer.  
Jobs can be created, deleted, renamed, analyzed and synced. All job commands are in the Job menu.  

- To create a new Job, select Job -> New.  
- To switch between Jobs, click Job tab.  
- Analyze, Sync, and Stop button are related to the current Job.  
- To delete a Job, select Job -> Delete.  

Sync Algorithm.  
This is a general outline of the synchronization algorithm (the actual algorithm is rather complex, it contains 
several important inventions and trade secrets that cannot be disclosed here):  
* Compute difference between current file state and stored file state for the left folder,  
* Compute difference between current file state and stored file state for the right folder,  
* Propagate changes that appeared on the left to the right side,  
* Propagate changes that appeared on the right to the left.  
* If change happened to same file on both sides, declare a Conflict.  

Conflicts.  
If you changed the file on both sides of the synchronized folder pair then GoodSync cannot determine which 
version is preferred (because it does not know which set of changes should win and which should be 
dropped) and GoodSync then declares a conflict. By default conflict is a no-copy operation. But you can 
change conflict into LeftToRight or RightToLeft Copy, thus declaring one side a winner.  

Backup Files Incrementally: One Way Sync.  
For GoodSync backup is a regular synchronization that happens to always be one-way, as long as user 
does not manually change backup files. Only changed files and file deletions are propagated to backup 
folder. This is how you setup a backup:  
- Create an empty backup destination folder. Backup destination folder must not be located on the same disk 
as source folder. It can be on removable disk (USB disk or portable hard drive) or another computer.  
- Let GoodSync do the first backup by synchronizing backup source folder to backup destination folder.  
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- After that, whenever you want to backup, just sync backup source folder to backup destination folder.  
- When you need to restore, backup destination folder contains exact copy of the backup source folder, as of 
last backup.  
- To make sure that backup always goes one way (from original folder to backup folder and never in the 
other direction), go into Jobs -> Options and select One Way Job Type.  

Filters: Exclusions and Inclusions.  
By default GoodSync synchronizes all files and folders present in left and right folder. Some of the files and 
folders (for instance, object files *.OBJ or backup files *.BAK) may be excluded from synchronization by 
using Exclusions mechanism.  

The easiest way to exclude the file or group of files is to right-click the file or folder and select one of the 
Exclusion commands:  
* Exclude '\FileName' file or folder.  
   Exclude only this file, as specified by its complete path '\FileName'.  
* Exclude All 'FileName' files or folders.  
   Exclude all files (at any of subfolders) that are named 'FileName'.  
* Exclude All '*.ext' files.  
   Exclude all files that have extension 'ext', in all folders.  

Any exclusion command adds a line to the list of exclusions that is stored in Jobs -> Options -> Filters.  
This option tab is the only place where you can modify or delete exclusions.  
For details see this tab description in Job -> Options -> Filters.  

By default GoodSync excludes hidden and system files, because these files are not user files and usually 
they are not worth backing up or syncing. If you want GoodSync to see these files, uncheck "Exclude Hidden 
Files" and "Exclude System Files" in Job -> Options -> Filters.  

Time Shift.  
FAT file system still used in Windows (especially for portable USB drives) has two unpleasant problems:  
- Local (not UTC) file modification time is stored, so moving between time zones may make your files appear 
to be changed even when none may have changed.  
- Modification time is stored with only 2 sec precision, so two files with slightly different modification times 
may actually be the same.  

This is how GoodSync addresses these two problems:  
- It ignores differences in mod time of +- 2 sec.  
- If many files have difference in modification times expressed as the same number of whole hours, this is 
declared a Time Shift. Time Shifts are a No Copy operation by default, but you can override the default by 
selecting Other -> Time Shift and then changing their sync direction using the arrows at the top.  

Copy State.  
If file is the same on the left and right side of the sync but the stored state of the file is not the same then 
GoodSync would perform special Copy State action for such files.  
Analyze results inform you that Copy State will be done, if this is necessary.  
You can see specific Copy State action using View -> Copy State or at the Details log level when Syncing.  

Job Templates.  
Job Template is an incomplete Job, usually with right folder not set. It is used to save your favorite set of Job 
options as a Template, so that other Jobs can be easily created from it.  
To create a Template from a Job, go to this Jobs and select File -> Save as Template.  

To create a new job from a saved template, select Job -> New.  
In the New Job dialog select From Template option.  
Then select template from which Job should be created.  
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Commands and Keyboard Shortcuts 
Job -> New    Alt+N  
Create New Job.  

Job -> Delete    Alt+D  
Delete this Job.  

Job -> Rename    Alt+R  
Rename this Job.  

Job -> Save as Template  
Save this job as a template that can be used when creating New Jobs.  

Analyze button or Job -> Analyze    Alt+A    F5  
Analyze this Job. Show proposed changes.  

Job -> Analyze All    F6  
Analyze all Jobs.  

Sync button or Job -> Synchronize    Alt+S    F7  
Synchronize this Job. Apply changes that Analyze has proposed.  

Job -> Synchronize All    F8  
Synchronize all analyzed Jobs.  

Job -> Analyze and Sync All    F9  
Analyze and then Sync each job.  

Cancel button or Job -> Cancel    Alt+C    ESC  
Stop analysis or synchronization of this Job. Also cancel ready-to-run status for other jobs.  

Job -> Open Job Log    Alt+L  
Open log file for this job. Log file shows all Analyzes, Syncs and individual file operations.  

Job -> Options    Alt+O  
Show Options dialog for this Job.  

Job -> Import from V4  
Import jobs from GoodSync V4.  

Job -> Reset State  
Delete GoodSync state files on both sides of this Job. Causes GoodSync to forget state info. Do not use this 
command unless directed by Support.  

Job -> Exit    Alt+X    F4  
Exit GoodSync.  

Click Tab    Alt+1 to Alt+9  
Select another job, make it current. Most commands in Job and Tree menu apply to the current job.  

Changes button or Tree -> Changes    Alt+G  
Show Changes, that is, only files and folder that are different.  
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Conflicts button or Tree -> Conflicts    Alt+F  
Show Conflicts, that is, files that were changed on both sides of the Job.  

Errors button or Tree -> Errors    Alt+E  
Show Errors that occurred during Analyze or Sync. Errors are not conflicts,, they come form Windows. 
Example: file is locked, cannot drill into folder when analyzing.  

Other -> All or Tree -> All  
Show All files and folders.  

Other -> Copy State or Tree -> Copy State  
Show Copy State files, that is, files for which GoodSync must copy state but not the file itself, because files 
are already the same.  

Other -> Time Shift or Tree -> Time Shift  
Show Time Shift files, that is, files for which size is the same but modification time differs by less than 2 
seconds or by whole number of hours.  

Other -> Copy Left or Tree -> Copy Left  
Show files that will be copied from Right to Left.  

Other -> Copy Right or Tree -> Copy Right  
Show files that will be copied from Left to Right.  

Other -> Deleted or Tree -> Deleted  
Show files and folders that will be deleted only.  

Other -> Excluded or Tree -> Excluded  
Show files and folders that were excluded by Exclude/Include filter.  

Context Menu -> Open Left File or Item -> Open Left File  
Open file on the left.  

Context Menu -> Open Right File or Item -> Open Right File  
Open file on the right.  

Context Menu -> Delete Both Files or Item -> Delete Both Files  
Delete file on the left and on the right.  

Context Menu -> Exclude '\...' File or Item -> Exclude '\...' File  
Exclude this file from Analyze.  

Context Menu -> Exclude All '...' Files or Item -> Exclude All '...' Files  
Exclude all files that have the same name as this file, but maybe sit in other folders.  

Context Menu -> Exclude All '*.ext' Files or Item -> Exclude All '*.ext' Files  
Exclude all files that have extension .ext, in all folders.  

Item -> Include All '*.ext' Files  
Include only files that have extension .ext, in all folders.  

View -> Filters  
Show/Hide Filters pane, it shows all Exclude and Include filters for this Job.  
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View -> Status Bar  
Show/Hide Status Bar.  

View -> Log  
Show/Hide Log pane, it shows log for this Job.  

View -> Program Options  
Show Global Program Options dialog.  

File Systems: Local and Remote 
GoodSync can synchronize not only disk and net shares mounted on your computer. It can also synchronize 
with Remote File Systems (FS) accessible through these protocols: FTP, Secure FTP (SSH), WebDAV.  

To select or change your sync folder, click Browse button on the left or right side of Sync.  
The Browse File System dialog appears.  

File System Type appears in the left navigation pane of the Browse dialog.  
To change File System Type, click on different file systems on the left.  

Then enter or edit your Remote Server Address in Address field (Remote FS only).  

Then enter UserID, Password and maybe other connection data (Remote FS only).  

Then click Go button to connect to the server and test whether the data you entered is correct.  

If connection is successful, the Home Folder of UserID you used is shown and all folders above it.  

Navigate to the folder to sync with in the folder tree.  

If folder you want to sync with does not exist, create it:  
navigate to its parent folder and click Make New Folder button.  

Below we provide detailed description of Local and Remote File Systems that GoodSync supports.  

My Computer  
Disks mounted directly on this computer.  
Naming convention used: Windows "disk letter + path", example: C:\folder1\folder2\file.ext  

Since no authentication is required and disks are always connected, the folder tree is shown right away 
(clicking Go button is not needed).  

My Network  
Net Shares (remotely mounted disk volumes) available through Microsoft networking.  
Naming convention used: Windows UNC, example: \\share\disk\folder1\folder2\file.ext  

List of available network shares is shown, then you can drill down to the sync folder.  

Enter UserID and Password if your share is password-protected by UserID and Password that is different 
from UserID and Password of the Windows account you are logged in to.  

You can mount shares both from Local Network (LAN) and from remote computers (WAN), see 
Synchronizing Via Network section below.  
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Note that once you logged in to Share, Windows will cache authentication data. So if authentication data 
changes on server, you must Logout and then Login to you account on the client to make Windows use new 
authentication data.  

FTP  
Remote FTP server.  
Naming convention used: URL with ftp:// prefix, example: ftp://server.domain.com/folder1/folder2/file.ext  
Extended naming convention adds port, auth data: ftp://userid:password@server.domain.com:port/folder/file  

UserID and Password are usually required.  
If you are connecting to public FTP archive, use UserID "anonymous" and Password 
"email@somewhere.com".  

Passive vs Active mode. By default GoodSync uses Passive FTP mode when connecting, because in this 
mode no data connections from server to client are required and these connections are not allowed by most 
firewalls. Check Active Mode box only if Passive mode connection times out and if you firewalls allow 
servers to initiate FTP data connection to the client.  

Secure FTP (FTP over SSH)  
Remote SSH server with SFTP capability.  
Naming convention used: URL with sftp:// prefix, example: sftp://server.domain.com/folder1/folder2/file.ext  
Extended naming convention adds port, auth data: 
sftp://userid:password@server.domain.com:port/folder/file  

Authentication data is always required, and it comes in two different varieties:  
* UserID + Password.  
Just like in FTP, UserID and Password are required to log in.  
* UserID + Private Key File.  
Private Key File is a small (1-2 Kb) file that contains the "private key" part of the Public - Private Key Pair.  
The Public Key is located on the server and only server administrator can put it there.  
Private Key may additionally be protected by a password. Enter this password into the Browse dialog or use 
private key caching program such as Pageant.  

We recommend to use SFTP over FTP whenever possible because:  
* SFTP encrypts UserID and Password it sends to server, so listener-in-between stealing of authentication 
data is not possible. FTP sends UserID and Password unencrypted.  
* SFTP encrypts all files that it transfers. FTP sends files as is, unencrypted.  

WebDAV  
Remote DAV server.  
Naming convention used: URL with http:// prefix, example: http://server.domain.com/folder1/folder2/file.ext  
Extended naming convention adds port, auth data: 
http://userid:password@server.domain.com:port/folder/file  

UserID and Password and it is always required.  

DAV is an upload-enabled extension of HTTP protocol. It means that some folders on the server may be 
HTTP only and some may allow DAV uploads. You cannot connect to HTTP-only folder using our DAV file 
system.  

Job Options 
Each Job has a set of options that modify the behavior of synchronization algorithm for this job.  

General tab 
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Sync Direction  
Synchronization direction can be one of the three choices below.  

2-Way (default value)  
Propagate changes from Left to Right and propagate changes from Right to Left.  

1-Way Left to Right  
Propagate changes only from Left to Right.  

1-Way Right to Left  
Propagate changes only from Right to Left.  

There is also two modifiers that apply only to 1-way syncs:  

Verified (default)  
If selected then GoodSync checks that files on destination side did not change and that changes 
occurred only on the source side of 1-way job. If a change on the destination side is found, it is 
declared to be a conflict.  

Forced  
If selected then GoodSync will always observe the preferred sync direction, even if it results in older 
files from the source side overwriting the newer files on the destination side. We recommend not to 
use this option (use Verified instead), as it may result in a loss of newer files that you accidentally 
modify on the backup side.  

Forced + Read-Only Source Side  
Forced Sync in which GoodSync does not write anything on the source side. Since state cannot be 
saved for the read-only source side, deletions cannot be propagated from the source side.  

Propagate Deletions (checked by default)  
If checked, then deletion made by user on one side of the job is propagated to the other side of the job.  
If not checked, then deletions are not propagated, only newer files are propagated.  
This option is assumed to be unchecked if Read-Only Source Side is checked.  

Move deleted/replaced files to _gsdata_\_saved_ (checked by default)  
If checked, then GoodSync saves a file just before Sync replaces or deletes this file. The file is saved to 
_gsdata_\_saved_ folder on the side where the replacement/deletion is about to occur. Only the most recent 
version of the file ( the one just before the current version) is retained.  

Safe Copy using Temp files (checked by default)  
If checked, then Sync does not copy source file directly to the destination file, as it would result in corruption 
of destination file is copy operation is aborted mid-copy. Instead Sync copies source file to temporary file in 
destination folder and once copy operation is finished, temporary file is renamed to the destination file.  
You may uncheck this option if you are doing 1-way backups and destination volume has small free space, 
so that keeping two copies of one big file may overflow it.  

Check Analyze-Sync File Stability on Remote File Systems (un-checked by default)  
If checked then verify that files did not change between Analyze and Sync both for Remote file systems and 
Local Windows file system.  
If un-checked then perform this verification only for Local Windows file system.  
Turning this option On slows down remote Syncs but guarantees better file integrity.  

Estimate disk space required for Sync (checked by default)  
If checked then Compute how much free disk space is needed to complete the Sync.  
Keep it On for jobs that write to drives with limited free space.  
Turn it Off for jobs that are unlikely to overflow disks, because free space is plentiful on both sides.  

Display Balloon messages  
This option controls whether and when balloon (system tray) messages are displayed.  

Never  
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Do not display balloon messages.  
On Conflicts and Errors (default)  

Display balloon messages only when Conflicts or Errors are detected during Analyze or Sync.  
On Changes and Sync  

Display balloon messages when Analyze detects Changes, Conflicts or Errors.  

Filters tab 

Excluded (empty by default)  
Files and folders that match any line on this list, will be excluded from synchronization.  
Wildcards '*' and '?' can be used here, just like in Windows command line.  
Matching is done with the relative file/folder path, that is, path that starts at the sync folder.  
Lines that start with '\' match complete folder paths relative to sync folder.  
Lines not starting with '\' will match any file name, but only relative path will be matched.  

Examples:  
*.obj matched all files with .obj extension.  
CVS matches all files and folder named CVS, anywhere in sync folders.  
\\Folder\\*.obj matches all *.obj files located in folder Folder that appears only in root sync folders.  
Folder\\*.obj matches all *.obj files located in folder Folder that appears in sync folders or their subfolders.  

Included (empty by default)  
If not empty then only files and folders whose names match one of the lines of this Included list and do not 
match any lines of the Excluded list, are included in synchronization.  

It is recommended for the set of inclusions and exclusions to be the same for all jobs that sync with one 
particular folder. Keeping them different is possible but it is likely to cause confusion as some jobs will not 
sync files that other jobs would sync.  

Exclude Empty Folders (un-checked by default)  
If checked then Exclude folders that are empty or that contain only empty folders. Folder are considered 
empty if they contain no files or if they contain only files that were Excluded by Filters.  

Exclude Hidden Files and Folders (checked by default)  
Exclude files and folders that have HIDDEN attribute.  

Exclude System Files and Folders (checked by default)  
Exclude files and folders that have SYSTEM attribute.  

Auto tab 

Analyze and Sync can be made to run automatically by using this tab.  

Check Analyze box for Analyze only to run on a specified event.  
Check Sync box for Sync to run on a specified event.  
If you check Sync box then Analyze box is checked too, because Analyze must be run before Sync.  

One or more events may be selected to cause automatic Analyze and/or Sync:  

Event: GoodSync start  
Analyze (and maybe Sync) this job when GoodSync starts.  

Event: Removable Disk Insert  
Analyze (and maybe Sync) this job when Removable device is inserted and  
Left or Right folder of this job is located on this inserted device.  
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More than one job per device can be started this way, these jobs run sequentially.  

Event: Logoff  
Analyze and then Sync this job just before Logoff from Windows.  
Note that Windows may try to kill GoodSync on Logoff. Normally Windows that GoodSync is performing file 
operations and responds to messages and it would let GoodSync finish. However this cannot be guaranteed.  

Event: Timer (Start Periodically)  
Analyze (and maybe Sync) this job periodically, every HH hours and MM minutes.  

Event: Using Task Scheduler  
Analyze (and maybe Sync) this job periodically, on a schedule set in Windows Task Scheduler.  
Click Configure to call up Windows Task Scheduler and set schedule in it.  

User Command: Analyze or Sync All Jobs  
When user selects "Job -> Analyze All", "Job -> Sync All" or "Job -> Analyze and Sync All", all jobs are 
executed sequentially using AutoRun mechanism.  

Command Line: Analyze or Sync command  
When GoodSync is started with command line that contains job command with /analyze or /sync option or 
analyze or sync command then all selected jobs are run sequentially using AutoRun mechanism.  

Option: Automatically Resolve Conflicts  
When job is about to be Synced automatically, use this option to automatically resolve conflicts:  

Do Not Copy (default value)  
Leave Conflicts in unresolved (Do Not Copy) state.  

Left to Right  
Resolve to Left to Right propagation.  

Right to Left  
Resolve to Right to Left propagation.  

Newer File Wins  
File with the most recent modification date wins.  

Option: No Sync if too many files changed (100% by default)  
Automated Sync is not performed if more than the specified (in percent) fraction of files in the Job has 
changed. Unusually high number of changed files indicates that something may be wrong and manual 
intervention is required. Set to 100% to Sync no matter how big the changes are.  

Option: Use Job Tags to ensure that the same folder is synced (un-checked by default)  
If checked, then a unique identifier called Job Tag is deposited into Left and Right folder and the Job itself to 
ensure that Sync is always performed on the same folders. The same folder path may lead to different 
folders, as in Windows the same drive letter may be assigned to different physical removable disks.  
If not checked, do not create or verify Job Tags. We recommend to keep this option turned on, as syncing 
with the wrong folder accidentally mounted in the place of the right folder may lead to catastrophic data loss.  

Continuous running of GoodSync  
GoodSync must be running all the time for these Auto events to work:  
- Removable Disk Insert  
- Logoff  
- Timer  

Therefore you should turn on these global program options:  
- Start GoodSync when Windows starts  
- Hide to System Tray when Main Window is closed  
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Job Scheduling  
Each event that has just occurred flags the job as ready-to-run.  
Ready-to-run jobs are run from left to right, sequentially, until all ready-to-run jobs have been run.  
If job is already in the ready-to-run state and another even occurs that wants to run the job then this 2nd 
event is ignored.  

Global Program Options 

General tab 

These global options apply to all jobs, to the entire GoodSync program.  
The are called by View -> Program Options command or ALT+P.  

Language (default: English)  
Select user interface language for GoodSync.  
You must restart GoodSync for the language change to become effective.  
Supported languages are listed on the Translations Page.  

Hide to System Tray when Main Window is closed (off by default)  
If checked then: When you Close GoodSync, it will run in the background.  
To access GoodSync, double-click GoodSync icon in System Tray (desktop lower right corner).  
If not checked, then: When you close GoodSync, it unloads from memory.  

Start GoodSync when Windows starts (off by default)  
If checked then Windows starts GoodSync automatically when you log in into your Windows account.  
Started this way, GoodSync shows only taskbar icon and no main window.  
You can double-click the icon to call up the main GoodSync window.  
Turn this option on if you run jobs automatically, that is, if you checked any boxed in Job Options -> Auto tab.  

Check for a new version daily (on by default)  
If checked then GoodSync will contact www.goodsync.com daily to check whether the new version is 
available.  

Create left/right Sync folders if they are not found (off by default)  
If checked then GoodSync will create left/right sync folders if they are not present.  
If not checked, then error message will be shown on Analyze if sync folders are not present.  

Save log file (on by default)  
If checked then GoodSync:  
* writes job log file named <JobName>_<yyyy>_<mm>.log to _gsdata_ folder of the left and right sync 
folders.  
* writes global log of its non job-specific actions to file named GoodSync_<Year>_<Month>.log and located 
in folder C:\Documents And Settings\<User Name>\Application Data\GoodSync.  
If not checked, then no log files are written.  

Clean up logs monthly (on by default)  
If checked, then keep log files for this month and for previous month and delete older log files.  
If not checked, keep all log files.  

Logging Level  

Critical  
Important non-error messages that must be seen.  

Error  
Errors that terminates a job, shown in red.  
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Information (default value)  
Warnings or major action performed, includes sync actions.  

Details  
Details on actions performed, no need for most users to see.  

Filters tab 

In addition to job-specific Included and Excluded filter you can specify global (program-wide) filters in this 
tab.  

The effective Excluded and Included filters used for the job are  
the sum of job-specific Excluded and Included filters and program-wide filters from this tab.  

About tab 

This tab show version and use information.  

It also contains Check for Updates button that checks www.goodsync.com for its most recent version.  

Command Line 
GoodSync can be started from command line and everything that you can do from GUI can be done using 
command line options described here.  

Command line call has this general format:  
goodsync [<global-option>] <command> <command-options>  

Global Options 

/help  
Show help message that lists command line options.  

/min  
Run minimized, only taskbar icon is visible.  

/profile=<profile-folder>  
Look for profile files jobs.tic (job list with options) and options.tic (global program options) in <profile-folder>.  
Path should be an absolute path on local computer.  

/lf=<log-folder>  
Write global log to <log-folder>. If not specified, write global log to profile folder.  
Path should be an absolute path on local computer.  

/ll=N  
Set log level to N (number from 1 to 3).  

/create-folder-if-notfound=yes|no  
Create job sync folders if not found.  

/exit  
GoodSync will exit upon completing the action requested in command line.  
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Commands 

analyze /all  
Analyze all jobs.  

analyze <job-list>  
Analyze listed jobs, job names are separated by space.  
Job names containing spaces must be enclosed in quotes like this: "Job Name"  

sync /all  
Synchronize all jobs.  

sync <job-list>  
Sync listed jobs, job names are separated by space.  
Job names containing spaces must be enclosed in quotes like this: "Job Name"  

job <job-name> [<job-options>]  
Create a new job or update an existing job with specified job options.  

job-new <job-name> [<job-options>]  
Create a job with specified job options.  

job-update <job-name> [<job-options>]  
Change specified options in the existing job.  

job-delete <job-name>  
Delete existing job.  

Job Options 

/analyze  
Analyze Job after it has been created or updated.  

/sync  
Analyze and Sync Job after it has been created or updated.  

/f1=<full-folder-path>  
Left sync folder.  

Full Folder Path should be in one of these formats:  
  C:\folder1\folder2\file.ext  
  \\share\disk\folder1\folder2\file.ext  
  ftp://userid:password@server.domain.com:port/folder/file  
  sftp://userid:password@server.domain.com:port/folder/file  
  http://userid:password@server.domain.com:port/folder/file  
Use quotes around paths with spaces.  

/f2=<full-folder-path>  
Right sync folder.  
For Full Folder Path format see the above item.  

/pk1=<folder-path>  
SFTP private key file absolute path, for left sync folder.  
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/pk2=<folder-path>  
SFTP private key file absolute path, for right sync folder.  

*** General Options ***  

/dir=2way | ltor,forced | ltor,verfied | rtol,forced | rtol,verfied  
Job direction: 2-way, Left to Right (ltor), or Right to Left (rtol).  
One Way Mode that appears after ltor or rtol can be: forced or verified.  

/readonly-src=yes|no  
Read-Only Source Side option. Can be turned on only for 1-way Forced job.  

/deletions=yes|no  
Propagate Deletions option.  

/save-disposed-files=yes|no  
Saved files overwritten or deleted by GoodSync to _saved_ folder in _gsdata_.  

/temp-dest-file=yes|no  
Use temporary files when copying from source to destination, so that sudden interruption of copy does not 
result in corrupted file.  

/check-file-stability=yes|no  
Check Analyze-Sync File Stability on Remote File Systems option.  

/est-req-space=yes|no  
Estimate Required Free Space option.  

/balloon-msg=none|errors|changes  
Show Balloon option.  

*** Filter Options ***  

/exclude=<file-mask>  
Exclude filter.  
File Mask is a comma-separated list of patterns such as *.obj or \folder\file.  

/include=<file-mask>  
Include filter.  
File Mask is a comma-separated list of patterns such as *.obj or \folder\file.  

/exclude-empty=yes|no  
Exclude Empty Folder option.  

/exclude-hidden=yes|no  
Exclude Hidden Files and Folders option.  

/exclude-system=yes|no  
Exclude System Files and Folders option.  

*** Auto Options ***  

/autoresolve=no|left|right|newer  
Auto-Resolve Conflicts option: No Copy, Left winds, Right wins, Newer wins.  
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/limit=<NN>  
No Sync If Too Many Files Changed option.  
NN is a number from 0 to 100.  

/jobtags=yes|no  
Use Job Tags option.  

Activation of Pro Version 

The options below are installer options, that is, they are specified for the installer GoodSync-Setup.exe, not 
for GoodSync.exe. 

/orderid=1234567890  
/username="John Smith"  
If /orderid and /username options are specified then GoodSync Pro is automatically activated upon install 
using the specified OrderID and User Name. Note that this is online activation, so GoodSync.exe should be 
able to get to www.goodsync.com.  

/proxy="Proxy User Name, Proxy Password"  
If online connection on your computer requires password-protected proxy and you are using /orderid 
and /username options then specify Proxy User Name and Proxy Password using this option.  

/S  
Run installer silently, no input from user is requested.  

Enterprise Activation 
For those deploying GoodSync in an Enterprise environment, you can install and activate using the above 
mentioned parameters of OrderID and Company Name from the purchase. An example being: 

GoodSync-Setup.exe /S /orderid=0123456789 /name="Company Name" 
This will run the GoodSync installer silently, and attempt to activate the software using the OrderID and 
Company Name specified. 

Syncing Specific Applications 
This section tells you how to setup syncing for popular applications.  

RoboForm.  
Latest versions of RoboForm have command RoboForm -> Tools -> Sync Data that setup sync job and start 
GoodSync automatically. If setting up manually, you should synchronize folder My RoboForm Data between 
two computers that you are syncing, or between computer and USB drive with RoboForm2Go. These 
computer-specific files will be excluded from sync: license.rfo, cache.rfo, mru.rfo. You may include file 
options.rfo, it contains RF options.  

Outlook.  
Synchronize file Outlook.pst that contains Outlook data. It usually is in the folder C:\Documents and 
Settings\User Name\Local Settings\Application Data\Microsoft\Outlook. Note that Outlook must be closed for 
this file to be synced. Open Outlook application locks this file, not allowing GoodSync to write it. If you use 
Active Sync to sync with phone or Pocket PC, then Outlook.pst file is locked as long as your phone is 
plugged in. So you should pull out your phone from the cradle for this file to be synced.  

Outlook Express.  
Outlook Express (OE) stores its data in several files, located in OE data folder. To find where this folder is, 
open OE and go to Tools -> Options -> Maintenance -> Store Folder. It will show you where the data files 
are and you can change this location of the folder too. Sync the entire folder. Sync only when OE is closed, 
as OE may lock the files it uses.  
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Quickbooks.  
Quickbooks (QB) stores all its data in one file that has format CompanyName.QBW. This is the file to sync. 
Quickbooks backup files have extension .QBB. We recommend to back up the QBW file using native QB 
Backup command and to sync the backup file too, for extra protection. Quickbooks locks the QBW when 
opened, so you must close QB before syncing. Even if you opened QBW file to only view it and not to modify 
it, QB will still modify this file. So you cannot use GoodSync for 2-way syncing of *.QBW files, you can do 
only 1-way backup.  

ACT!  
Act locks its data files and when you close ACT, they are still locked. This is because ACT! installs a SQL 
service that is active even when the ACT! application is not running. This service keeps ACT! data files 
locked. You should stop the MSSQL ACT! service temporarily to be able to sync these files: Go to 
Start/Control Panel/Administrative Tools/Services, locate the service named "MSSQL$ACT7" (or something 
similar), stop it, do the synchronization, and then start the service again. Alternatively, you can permanently 
exclude ACT! files from synchronization.  

Mounting Folder via Network: Tutorials 
GoodSync synchronizes folders that are mounted on the computer on which GoodSync runs.  
Mounting folder on a computer uses Windows machinery and other programs.  

We provide tutorils that explain how to do it, even though the exact recipee of how to mount a drive via 
Network lies outside of scope of GoodSync manual.  

Sync files between Two Computers on Local Network.  
First you need to decide which computer is Client and which is Server.  
Server computer must have Sharing turned on and folder to sync must be Shared on the Server.  
Client computer must have GoodSync installed. Client computers mounts folder to share from Server.  
Both computers must be sitting on the same Local Network (LAN).  
Usually a bigger computer that is constantly connected to the network gets to be the Server and smaller 
computer that is not always connected gets to be the client. In Desktop to Laptop syncing Desktop will be the 
Server and Laptop will be the Client.  

1. Share Folder on Server Computer (done once per folder).  
Open folder to share in My Computer or in Windows Explorer.  
Right-click the folder and select Sharing and Security.  
Click "Share this folder on the network".  
Assign Share Name to your folder, this name will be what you see on the Client.  
Check box "Allow network users to change my files". GoodSync should be able to read and write files in the 
folder you share.  
Click OK and wait for Windows to set permissions on the folder.  

1a. Share entire Disk on Server Computer (alternative to sharing individual folders).  
You may want to share not just one folder, but the entire disk, in this case you do not have to go through 
folder sharing procedure for every folder you need to sync. This is how:  
in My Computer or Windows Explorer right-click Disk drive,  
select Sharing and Security,  
check Share This Folder.  

2. Set or Get your Server Name (done once per server computer).  
On Server computer right-click My Computer and select Properties, then click Computer Name tab.  
Full Computer Name shows the Name of your Server computer.  
If this name is meaningless, change it to something you can recognize by clicking Change button. Usually 
computers are named after person who uses them or their location. Examples: Scott Laptop, Suzie Dell.  

3. Mount Shared Folder on the Client.  
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Now go to the Client computer where GoodSync is installed.  
Select Job -> New to create a New Job and name this job.  
Click left Browse button and select folder on the Client computer to sync with.  
Click right Browse button. This is where we will enter the shared folder that we mount from Server to the 
Client.  
Select My Network tab, it shows a list of computers visible on your network.  
Select the Server computer, open it and select the folder that you Shared on server.  
Click OK and you Job is ready to Analyze and Sync.  
If your computer is not immediately visible in My Network, you can type direct address of the Shared folder 
as \\ServerName\ShareName where ServerName is the name of your Server and ShareName is the name 
that you assigned to the shared folder.  

Sync files between two computers on the Internet: Non-Secure.  
We are syncing between two computers (Client and Server) by mounting network disk via Internet.  
- Windows file sharing does not encrypt file contents in transit, nor does it encrypt disk sharing passwords 
that you use. So this method is not secure, as 3rd parties listening on your network can sniff out passwords 
and file contents.  
- Share a disk on a Server computer: in Windows Explorer right-click drive, select Properties, go to Sharing 
tab, check Share This Folder on the Network.  
- Make Server computer accept connections on port 139. If you have a software or hardware firewall, config 
this firewall to allow incoming connections on port 139.  
- On a Client computer type this into Address bar of Windows Explorer: "\\111.222.333.444\Share". Here 
111.222.333.444 is IP address of the Server Computer and Share is share name of the shared disk on the 
Server Computer. You should see the Server folder that you shared.  
- Start GoodSync on Client Computer and type the same \\111.222.333.444\Share into the sync folder path. 
Now you can sync.  

Sync files between two computers on the Internet: Secure.  
We are syncing between two computer (Client and Server) by tunnelling disk mount via SSH.  
- Install a suitable SSH server on Server Computer or on a computer that sits on a local network with Server 
Computer. Using cheap Linux box with SSH as a gateway is an option.  
- Install a suitable SSH client on Client Computer.  
- Configure SSH client to tunnel connections from port 139 on Client Computer to port 139 on Server 
Computer, that is, to IP address of the Server as seen from the computer where SSH server runs.  
- Establish an SSH connection from Client to Server.  
- On a Client computer type this into Address bar of Windows Explorer: "\\127.0.0.1\Share". Here 127.0.0.1 
is address of localhost (that is, Client Computer). Windows Explorer connects to port 139 on Client 
Computer, SSH client tunnels this connection to the Server computer via SSH server.  
- You cannot share other disks on Client Computer, as there is only one port 139 on the computer and it will 
be taken by disks you share locally. Non-trivial workarounds exist for this limitation.  
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